Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 27 lines (23 sloc) 0.523 kB
ddb9f72 @mikel Updating Gemfile
mikel authored
1 source :rubygems
b4d5e6b @dchelimsky update Gemfile to bundler-0.9
dchelimsky authored
2
8bea8ed @mikel Making further changes for active support removal
mikel authored
3 gem "activesupport", ">= 2.3.6"
8990e3d @mikel Updating Rakefile to work with new Bundler. Update gemfile to only r…
mikel authored
4 gem "tlsmail" if RUBY_VERSION <= '1.8.6'
ddb9f72 @mikel Updating Gemfile
mikel authored
5 gem "mime-types", "~> 1.16"
715453e @mikel Updating treetop version, specs now run 20-30% faster
mikel authored
6 gem "treetop", "~> 1.4.10"
a62169e @mikel Updating Gemfile to match gemspec
mikel authored
7 gem "i18n", ">= 0.4.0"
d9a56c2 @ultraninja Add a Gemfile to easily setup the test dependencies
ultraninja authored
8
8bea8ed @mikel Making further changes for active support removal
mikel authored
9 if defined?(RUBY_ENGINE) && RUBY_ENGINE == 'jruby'
10 gem 'jruby-openssl'
11 end
12
b4d5e6b @dchelimsky update Gemfile to bundler-0.9
dchelimsky authored
13 group :test do
ec98e3e @mikel Updating gemfile
mikel authored
14 gem "rake", "> 0.8.7"
48e8740 Upgrade rspec 2.8.0
Jason Stirk authored
15 gem "rspec", "~> 2.8.0"
75f2c02 @mikel Adding case statement for all the different rubies... bit redundant b…
mikel authored
16 case
17 when defined?(RUBY_ENGINE) && RUBY_ENGINE == 'rbx'
18 # Skip it
19 when RUBY_PLATFORM == 'java'
20 # Skip it
21 when RUBY_VERSION < '1.9'
22 gem "ruby-debug"
23 else
24 # Skip it
f35decc @mikel Bypassing ruby-debug if we are using JRuby or Rubinius
mikel authored
25 end
d9a56c2 @ultraninja Add a Gemfile to easily setup the test dependencies
ultraninja authored
26 end
Something went wrong with that request. Please try again.