New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

conemuc -guimacro rename 0, "new title" very slow (1 second) #101

Closed
jasir opened this Issue Apr 14, 2015 · 6 comments

Comments

Projects
None yet
2 participants
@jasir

jasir commented Apr 14, 2015

Hello,

Renaming of tab is very slow, is this normal? Thank you!

$ time conemuc -guimacro rename 0, "new title"
  OK

  real    0m1.072s
  user    0m0.000s
  sys     0m0.046s
@jasir

This comment has been minimized.

Show comment
Hide comment
@jasir

jasir Apr 14, 2015

The same slowness is for evert conemuc invocation:

$ time conemuc -guimacro print abc
OK

real    0m1.079s
user    0m0.015s
sys     0m0.047s

Only help is fast:

$ time conemuc 
...help...
real    0m0.064s
user    0m0.015s
sys     0m0.031s

jasir commented Apr 14, 2015

The same slowness is for evert conemuc invocation:

$ time conemuc -guimacro print abc
OK

real    0m1.079s
user    0m0.015s
sys     0m0.047s

Only help is fast:

$ time conemuc 
...help...
real    0m0.064s
user    0m0.015s
sys     0m0.031s
@Maximus5

This comment has been minimized.

Show comment
Hide comment
@Maximus5

Maximus5 Apr 14, 2015

Owner

All GuiMacro are executed in GUI.
Connection needs time.

Owner

Maximus5 commented Apr 14, 2015

All GuiMacro are executed in GUI.
Connection needs time.

@jasir

This comment has been minimized.

Show comment
Hide comment
@jasir

jasir Apr 14, 2015

Ok, thanks for explanation. Should I close the issue or do you want it to let it open for possible improvement in future?

jasir commented Apr 14, 2015

Ok, thanks for explanation. Should I close the issue or do you want it to let it open for possible improvement in future?

@jasir

This comment has been minimized.

Show comment
Hide comment
@jasir

jasir Oct 7, 2015

Great. since build 151006 seems issue has been fixed. See #350 Perfect

 $ time conemuc -guimacro rename 0, "new title"
 OK
 real    0m0.053s
 user    0m0.000s
 sys     0m0.000s

jasir commented Oct 7, 2015

Great. since build 151006 seems issue has been fixed. See #350 Perfect

 $ time conemuc -guimacro rename 0, "new title"
 OK
 real    0m0.053s
 user    0m0.000s
 sys     0m0.000s

@jasir jasir closed this Oct 7, 2015

@jasir

This comment has been minimized.

Show comment
Hide comment
@jasir

jasir Mar 22, 2016

Seems is back again...

$ time conemuc -guimacro rename 0, "new title"
OK

real 0m1.055s
user 0m0.000s
sys 0m0.015s

jasir commented Mar 22, 2016

Seems is back again...

$ time conemuc -guimacro rename 0, "new title"
OK

real 0m1.055s
user 0m0.000s
sys 0m0.015s

@jasir jasir reopened this Mar 22, 2016

Maximus5 added a commit that referenced this issue Mar 25, 2016

gh-101: Switch `-UseExport` may be specified before `-GuiMacro` to ex…
…port result as env.var.

  Without `-UseExport` specified before `-GuiMacro`, ConEmuC.exe will not try
  to export GuiMacro result as environment variable `ConEmuMacroResult`
  to the parent process.
@jasir

This comment has been minimized.

Show comment
Hide comment
@jasir

jasir May 3, 2016

Just let you know, I have upgraded to newest (160428) and issue is gone again. Thank you

jasir commented May 3, 2016

Just let you know, I have upgraded to newest (160428) and issue is gone again. Thank you

@jasir jasir closed this May 3, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment