Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Crash at start with Far as default shell (only x64 builds) #1061

Open
nick133 opened this issue Mar 9, 2017 · 4 comments
Open

Crash at start with Far as default shell (only x64 builds) #1061

nick133 opened this issue Mar 9, 2017 · 4 comments
Labels

Comments

@nick133
Copy link

@nick133 nick133 commented Mar 9, 2017

Versions

ConEmu build: 161206, 170305 x64
OS version: Windows 8.1 Corporate x64
Used shell version: Far Manager, version 3.0 (build 4774) x64
Window manager: bblean (blackbox for windows)

Problem description

ConEmu crashes at start when default shell is Far.
Same repeats for 16120 and 170305 x64 builds.
In some rare case it starts mystically as expected, but when I press and hold 'Esc' (show/hide Far panels) - Far panels start blinking and then ConEmu crashes.

NOTE: x32 builds of both versions work fine. Old version 150813g x64 also works fine.

Steps to reproduce

  1. Run ConEmu x64 with a settings below
  2. If it starts - press and hold 'Esc'

Actual results

ConEmu throws an exception with saving memory dump:
Exception 0xC0000005 (Read x0000004EBDBDF7EE) was occurred (ConEmu64.exe, PID=4236)

Expected results

Normal execution

Additional files

Settings: ConEmu.xml

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Mar 9, 2017

I believe it depends on your Far settings and panels contents.
Crash dump is appreciated.

@Maximus5 Maximus5 added the type-crash label Mar 9, 2017
@nick133
Copy link
Author

@nick133 nick133 commented Mar 9, 2017

Both Far panels are on disk C: (no removable media). Regarding Far settings, as I stated, it starts successfully with the same settings and x32 builds (and also with old ConEmu version).

Here's a crash dump

@nick133
Copy link
Author

@nick133 nick133 commented Mar 9, 2017

Sorry I didn't find it before posting an issue but I guess it's exactly the same Issue. At least in both cases no explorer.exe is runnig.

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Mar 9, 2017

No, your problem has different source.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.