New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Firefox build fails in conemu 170316 and newer #1087

Open
Archaeopteryx opened this Issue Mar 30, 2017 · 0 comments

Comments

Projects
None yet
2 participants
@Archaeopteryx

Archaeopteryx commented Mar 30, 2017

This issue can be prevented by going into Settings > Features > In-console options > Inject ConEmuHk (thanks @gijsk), but one will e.g. use color support.

ConEmu build: 170326 x64 (also applies to 20170316)
OS version: Windows 8.1 x64
Used shell version (Far Manager, git-bash, cmd, powershell, cygwin, whatever):
GNU bash, version 3.1.23(1)-release (i686-pc-msys)

Problem description

Firefox artifact builds fail. Going back to 20170305 fixes the issue. Another person can also reproduce the issue with 170326 (I did 5x with 170326 and once with 170316). Building with 170305 succeeds.

Steps to reproduce

  1. Launch a normal Windows command shell in ConEmu.
  2. Call start-shell.bat from the installed MozillaBuild tools
  3. Try to do an artifact build of Firefox from ConEmu

Actual results

Artifact build fails with an error message (see log below). There is also the message "The system cannot find the file specified."

Expected results

Build passes, no errors shown.

Output build failure

Thank you for ConEmu and for looking into this.

EDIT: Got also a report that this affects normal compiling.

@Archaeopteryx Archaeopteryx changed the title from Firefox artifact build fails in conemu 170316 and newer to Firefox build fails in conemu 170316 and newer Mar 31, 2017

@Maximus5 Maximus5 added the hooks label Apr 2, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment