New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Arrows keys don't work in git bash when shortcut is pinned to start #1199

Closed
tpv-ebben opened this Issue Jul 21, 2017 · 5 comments

Comments

Projects
None yet
4 participants
@tpv-ebben

Versions

ConEmu build: 170709 x64
OS version: Windows 10 x64
Used shell version (Far Manager, git-bash, cmd, powershell, cygwin, whatever): bash (git-bash) 4.4.12(1)
Git for Windows version: 2.13.3

Problem description

Arrows keys don't work in git bash when shortcut is pinned to start

Steps to reproduce

  1. Pin ConEmu to start menu
  2. open

Actual results

Arrow keys do not work

Expected results

Arrow keys working

Additional files

Logs: https://drive.google.com/file/d/0B_7HkYKg6xoUbE9IWEpUakxIXzQ/view?usp=sharing

@tpv-ebben

This comment has been minimized.

Show comment
Hide comment
@tpv-ebben

tpv-ebben Jul 21, 2017

This is the task for Git Bash:
set "PATH=%ConEmuDir%\..\Git\usr\bin;%PATH%" & "%ConEmuDir%\..\Git\git-cmd.exe" --no-cd --command=%ConEmuBaseDirShort%\conemu-msys2-64.exe /usr/bin/bash.exe -l -i -new_console:p

It appears to already be using the connector.

This is the task for Git Bash:
set "PATH=%ConEmuDir%\..\Git\usr\bin;%PATH%" & "%ConEmuDir%\..\Git\git-cmd.exe" --no-cd --command=%ConEmuBaseDirShort%\conemu-msys2-64.exe /usr/bin/bash.exe -l -i -new_console:p

It appears to already be using the connector.

@Maximus5

This comment has been minimized.

Show comment
Hide comment
@Maximus5

Maximus5 Jul 21, 2017

Owner

I see.

Owner

Maximus5 commented Jul 21, 2017

I see.

@DominikJaniec

This comment has been minimized.

Show comment
Hide comment
@DominikJaniec

DominikJaniec Aug 4, 2017

I had also experienced this problem, but since few days ago I could not reproduce this case.

One difference in my case is that I'm using a flag: -Dir when running desktop's shortcut, which is pinned to the Start Bar / Taskbar.

I had also experienced this problem, but since few days ago I could not reproduce this case.

One difference in my case is that I'm using a flag: -Dir when running desktop's shortcut, which is pinned to the Start Bar / Taskbar.

@Maximus5 Maximus5 closed this Aug 4, 2017

@MrChozo

This comment has been minimized.

Show comment
Hide comment
@MrChozo

MrChozo Sep 6, 2017

I experienced this issue after installing ConEmu yesterday. @DominikJaniec, how/why do you apply the -Dir flag to run a pinned shortcut? After unpinning and restarting ConEmu, the issue seems to have gone away.

MrChozo commented Sep 6, 2017

I experienced this issue after installing ConEmu yesterday. @DominikJaniec, how/why do you apply the -Dir flag to run a pinned shortcut? After unpinning and restarting ConEmu, the issue seems to have gone away.

@Maximus5

This comment has been minimized.

Show comment
Hide comment
Owner

Maximus5 commented Sep 6, 2017

LogFiles please

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment