Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

wrong title bar #1369

Closed
yfinkel opened this issue Dec 21, 2017 · 26 comments
Closed

wrong title bar #1369

yfinkel opened this issue Dec 21, 2017 · 26 comments
Projects

Comments

@yfinkel
Copy link

@yfinkel yfinkel commented Dec 21, 2017

ConEmu build: 171217 x32/x64
OS version: Windows 10 x32/x64 (1709)

In the version 171217 with "Hide caption always" sometimes (not always, but very often) there is wrong drawing of the title bar:

2017-12-21 19 00 30

After moving the mouse cursor over the title bar:

2017-12-21 19 02 28

And this is right drawing (after minimize and restore):

2017-12-21 19 02 40

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Dec 21, 2017

I've never seen that. It may help if you can determine repro steps.

@yfinkel
Copy link
Author

@yfinkel yfinkel commented Dec 22, 2017

@elijahgagne
Copy link

@elijahgagne elijahgagne commented Dec 22, 2017

I've noticed this on 171217 as well (didn't notice it on previous builds). It happens infrequently and goes away with a window refresh. I don't have reliable steps to reproduce it. Definitely not a big deal to me.

@yfinkel
Copy link
Author

@yfinkel yfinkel commented Dec 27, 2017

No, nothing changed.

@elijahgagne
Copy link

@elijahgagne elijahgagne commented Dec 27, 2017

Agreed, I'm still seeing the issue after update.

2017-12-27 08_08_19-

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Dec 27, 2017

Does it happen if you run ConEmu64.exe -log -basic -run {cmd} ?
Do you run ConEmu window maximized?
Can you record a video reproducing the problem?

@elijahgagne
Copy link

@elijahgagne elijahgagne commented Dec 27, 2017

I am testing with "ConEmu64.exe -log -basic -run {cmd}" - will follow up
I don't run ConEmu maximized.
Here's a video of it.

conemu-title-bar

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Dec 27, 2017

Please upload log files.
So you do minimize ConEmu window and wait until aero thumbnail appears. Did you click on thumbnail or just hover the mouse cursor to reveal the aero peek?

@elijahgagne
Copy link

@elijahgagne elijahgagne commented Dec 27, 2017

In this case, I just hovered to reveal the aero peek. However, I usually see this issue just after opening ConEmu for the first time or after minimizing some other large window that was covering ConEmu.

So far I haven't seen the issue with "-log -basic", but assuming I do, I'll upload the logs.

@elijahgagne
Copy link

@elijahgagne elijahgagne commented Dec 27, 2017

While using "-log -basic" I opened a new tab with putty and got this:

2017-12-27 11_29_28-

Attached are the logs:
logs.zip

@Maximus5 Maximus5 added this to To Do in ConEmu via automation Jan 1, 2018
@Maximus5 Maximus5 moved this from To Do to Ready for Testing in ConEmu Jan 6, 2018
@yfinkel
Copy link
Author

@yfinkel yfinkel commented Jan 9, 2018

Alas, the same issue. (I now prefer to use 171109)

@elijahgagne
Copy link

@elijahgagne elijahgagne commented Jan 9, 2018

Still seeing the issue:

2018-01-09 09_05_19-wrong title bar issue 1369 maximus5_conemu

Sometimes it's worse now where the title bar is completely gone and nothing is showing main window:

2018-01-09 09_29_59-egagn

I don't run ConEmu maximized, but I do generally run it covering about 80% of my screen space. If I make the window very small (better for screenshots) I have been unable to reproduce the issue.

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Jan 9, 2018

I'm not able to reproduce it on my PC

@Maximus5 Maximus5 moved this from Ready for Testing to In progress in ConEmu Jan 11, 2018
@elijahgagne
Copy link

@elijahgagne elijahgagne commented Jan 11, 2018

In this version and the last, I am able to reliably reproduce this issue

conemu

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Jan 11, 2018

Seems like the behavior was changed? Fake TitleBar doesn't appear anymore?

Please make LogFiles and reproduce. At the moment the problem appears, make screenshot (I need the time to find in logs).

@elijahgagne
Copy link

@elijahgagne elijahgagne commented Jan 11, 2018

logs-title-bar.zip contains logs and screenshots

@yfinkel
Copy link
Author

@yfinkel yfinkel commented Jan 15, 2018

It seems to be corrected now - in my first tests. I'll try more later.

@bkrahl-nli
Copy link

@bkrahl-nli bkrahl-nli commented Jan 15, 2018

With build 180114 I am now getting this if I bring back ConEmu to front with "Minimize/Restore" hotkey:
tabbar

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Jan 15, 2018

@bkrahl-nli Attach your settings please. Window state before minimization: normal/maximized/fullscreen?

@elijahgagne
Copy link

@elijahgagne elijahgagne commented Jan 15, 2018

I've been running this for about five hours and it's looking fixed on my machine.

There is one very minor thing I've noticed and it's that I see a small "jitter" after bringing a Putty window to focus. I don't see the jitter bringing other native console windows to focus. After the window settles, I don't see the jitter.

conemu

I personally would not consider this a bug and do not see any need to work on fixing it.

@bkrahl-nli
Copy link

@bkrahl-nli bkrahl-nli commented Jan 15, 2018

@Maximus5 Display issue occurs in window state normal and maximized, but not if in full-screen mode. If the windows is minimized and brought back to previous state via Hotkey everything is normal. If the window is in background or out of focus and brought back to front or in focus via Hotkey this error occurs to me.

The display issue does not occur to me if the window is brought back to front by regular task switching instead of using the "Minimize/Restore" hotkey!
ConEmu.zip

@Maximus5 Maximus5 moved this from In progress to Ready for Testing in ConEmu Jan 29, 2018
Maximus5 added a commit that referenced this issue Jan 29, 2018
@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Feb 6, 2018

@yfinkel How about 180206?

@yfinkel
Copy link
Author

@yfinkel yfinkel commented Feb 7, 2018

Seems to be OK.

@Maximus5 Maximus5 closed this Feb 7, 2018
ConEmu automation moved this from Ready for Testing to Done Feb 7, 2018
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
ConEmu
  
Done
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
4 participants
You can’t perform that action at this time.