Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Splitting windows crashes ConEmu #1532

Closed
Habitats opened this issue Apr 28, 2018 · 10 comments
Closed

Splitting windows crashes ConEmu #1532

Habitats opened this issue Apr 28, 2018 · 10 comments
Projects

Comments

@Habitats
Copy link

@Habitats Habitats commented Apr 28, 2018

Versions

ConEmu build: 180427 x64
OS version: Windows 10 x64
Used shell version: Any shell

Problem description

Splitting windows crashes ConEmu. No error visible. It just quits. It works fine in 180422.

Steps to reproduce

Split any shell using
image

Actual results

Crashes with no error.

Expected results

Windows should've split.

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Apr 28, 2018

The Move splitter upward does not do split, it does just as it say - moves the splitter between splits.

And there is no "crash" on my side.

I don't believe... Why do you think that "it just quits"?

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Apr 28, 2018

Have you checked process list?

@tplk
Copy link

@tplk tplk commented Apr 28, 2018

Same here, when I try to split using hotkey, ConEmu crashes.

@seritools
Copy link

@seritools seritools commented Apr 28, 2018

Versions
ConEmu build: 180427 x64
OS version: Windows 10 x64 Insider Fast
Used shell version: Any shell

For me, something like "split to right" (used to cause that assertion error fixed in this build) now closes conemu (normal conhost/powershell now visibile), and after a few seconds I get:

ConEmuC64 PID=18324
---------------------------
Available ConEmu GUI window not found!
---------------------------
Retry   Cancel   
---------------------------

Hmu if you need more specifics!

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Apr 28, 2018

Please attach any debugger to ConEmu GUI (for example, ConEmuC64.exe /DEBUGPID=<ConEmuGuiPID>) and try to reproduce. Is there exception or crash?

@Maximus5 Maximus5 added this to To Do in Inspection via automation Apr 28, 2018
@seritools
Copy link

@seritools seritools commented Apr 28, 2018

This is what I got:

The thread 0x3a14 has exited with code 0 (0x0).
Critical error detected c0000374
ConEmu64.exe has triggered a breakpoint. occurred

Call Stack:

>	ntdll.dll!RtlReportCriticalFailure�()	Unknown	Non-user code. Symbols loaded.
 	ntdll.dll!RtlpHeapHandleError�()	Unknown	Non-user code. Symbols loaded.
 	ntdll.dll!RtlpHpHeapHandleError�()	Unknown	Non-user code. Symbols loaded.
 	ntdll.dll!RtlpLogHeapFailure�()	Unknown	Non-user code. Symbols loaded.
 	ntdll.dll!RtlFreeHeap()	Unknown	Non-user code. Symbols loaded.
 	AcLayers.dll!NS_FaultTolerantHeap::APIHook_RtlFreeHeap(void *,unsigned long,void *)	Unknown	Non-user code. Symbols loaded.
 	ConEmu64.exe!00007ff71010b678()	Unknown	No symbols loaded.
 	ConEmu64.exe!00007ff710113b19()	Unknown	No symbols loaded.
 	ConEmu64.exe!00007ff71009e4d6()	Unknown	No symbols loaded.
 	ConEmu64.exe!00007ff710062cc2()	Unknown	No symbols loaded.
 	ConEmu64.exe!00007ff710064d0f()	Unknown	No symbols loaded.
 	ConEmu64.exe!00007ff7100633bd()	Unknown	No symbols loaded.
 	ConEmu64.exe!00007ff710064d0f()	Unknown	No symbols loaded.
 	ConEmu64.exe!00007ff7100691c4()	Unknown	No symbols loaded.
 	ConEmu64.exe!00007ff71006c273()	Unknown	No symbols loaded.
 	ConEmu64.exe!00007ff7100e4999()	Unknown	No symbols loaded.
 	ConEmu64.exe!00007ff7100e77bc()	Unknown	No symbols loaded.
 	ConEmu64.exe!00007ff7100e7d28()	Unknown	No symbols loaded.
 	[External Code]		Annotated Frame
 	ConEmu64.exe!00007ff710027b59()	Unknown	No symbols loaded.
 	ConEmu64.exe!00007ff71002743f()	Unknown	No symbols loaded.
 	ConEmu64.exe!00007ff71002af1a()	Unknown	No symbols loaded.
 	ConEmu64.exe!00007ff71012113a()	Unknown	No symbols loaded.
 	[External Code]		Annotated Frame

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Apr 28, 2018

Does it suggest to create a dump?

@seritools
Copy link

@seritools seritools commented Apr 28, 2018

Hey, VS didn't suggest it, but I created one via the Debug menu entry. Sent you a mail with the dump. :)

@Habitats
Copy link
Author

@Habitats Habitats commented Apr 29, 2018

@Maximus5 yes, sorry, posted the wrong screenshot in the main post. I meant splitting, not moving the splitters, as others have pointed out. I've updated the issue with the correct screenshot. My crashing behavior is that of which @seritools explained.

@Maximus5 Maximus5 removed this from To Do in Inspection Apr 29, 2018
@Maximus5 Maximus5 added this to To Do in ConEmu via automation Apr 29, 2018
@Maximus5 Maximus5 moved this from To Do to Ready for Testing in ConEmu Apr 29, 2018
@seritools
Copy link

@seritools seritools commented May 1, 2018

Just tested with 180429 - fixed for me! :) Thanks

@Maximus5 Maximus5 closed this May 5, 2018
ConEmu automation moved this from Ready for Testing to Done May 5, 2018
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
ConEmu
  
Done
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
4 participants