New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Text being deleted with right arrow key on CentOS nano #1557

Open
kmichailg opened this Issue May 14, 2018 · 6 comments

Comments

2 participants
@kmichailg

kmichailg commented May 14, 2018

Versions

ConEmu build: 180506 x64
OS version: Windows 10 x64
Used shell version (MSYS2-ZSH via cmder): zsh 5.4.2 (x86_64-pc-msys)

Problem description

Text is deleted/unrendered(?) when browsing to the right on CentOS nano editor.
Issue is non-existent on Ubuntu nano editor with some limited testing.

Not sure if this is the right venue to report it or should I report to MSYS2, would appreciate to be pointed in the right direction.

Steps to reproduce

  1. Using default auto-generated task for MSYS2 bash and changing to zsh instead, open up terminal.
  2. SSH into a CentOS server, open up any text file.
  3. Move cursor to the right.

Actual results

Deletes/hides text (see gif below)
conemu ssh nano

Expected results

Normal text browsing.

Additional files

I have tried this fix and unfortunately does not work.

@Maximus5

This comment has been minimized.

Owner

Maximus5 commented May 14, 2018

What is the content of your task?

@kmichailg

This comment has been minimized.

kmichailg commented May 15, 2018

Thanks for replying @Maximus5. Please see below for my task:

-new_console:d:D:\Storage\Workspace set CHERE_INVOKING=1 & set "PATH=%ConEmuDir%\..\..\..\MSYS2\usr\bin;%PATH%" & %ConEmuBaseDirShort%\conemu-msys2-64.exe -new_console:p %ConEmuDir%\..\..\..\MSYS2\usr\bin\zsh.exe -l -i -new_console:C:"%ConEmuDir%\..\..\..\MSYS2\msys2.ico"

Default task for MSYS2 is:
set CHERE_INVOKING=1 & set "PATH=%ConEmuDir%\..\..\..\MSYS2\usr\bin;%PATH%" & %ConEmuBaseDirShort%\conemu-msys2-64.exe -new_console:p %ConEmuDir%\..\..\..\MSYS2\usr\bin\bash.exe --login -i -new_console:C:"%ConEmuDir%\..\..\..\MSYS2\msys2.ico"

Identical save for the startup directory and the -l -i arguments, which I've already switched around a couple of times. Could I have set something wrong on my end?

@kmichailg

This comment has been minimized.

kmichailg commented May 15, 2018

Additional info:

  • I installed zsh through the pacman package manager
  • Set up oh-my-zsh manually through git clone
  • Installed this theme and followed instructions
  • Installed zsh-autosuggestions and zsh-syntax-highlighting
  • I also have the MSYS2 version of nano installed locally, but I think that shouldn't be an issue since I'm ssh-ed into the CentOS server. Or is it causing a conflict?
@Maximus5

This comment has been minimized.

Owner

Maximus5 commented May 15, 2018

Please add after conemu-msys2-64.exe logging switch --log c:/temp (or some othe folder).
Run the task, reproduce the problem recording gif and upload here link to logfile (gist?) and new gif.

@Maximus5 Maximus5 added this to To Do in ANSI via automation May 15, 2018

@Maximus5 Maximus5 added the ansi label May 15, 2018

@kmichailg

This comment has been minimized.

kmichailg commented May 15, 2018

Attached the gist here.
Redacted some sensitive info (IP Addresses and domain names).

@Maximus5

This comment has been minimized.

Owner

Maximus5 commented Jun 16, 2018

I can reproduce the gh-1259

Maximus5 added a commit that referenced this issue Jun 17, 2018

Maximus5 added a commit that referenced this issue Jun 17, 2018

@Maximus5 Maximus5 added this to To Do in ConEmu via automation Jun 17, 2018

@Maximus5 Maximus5 moved this from To Do to Done in ANSI Jun 17, 2018

@Maximus5 Maximus5 moved this from To Do to Ready for Testing in ConEmu Jun 17, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment