Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

WSL bash doesn't launch with 190224 #1835

Closed
zbrozek opened this Issue Feb 25, 2019 · 19 comments

Comments

Projects
@zbrozek
Copy link

zbrozek commented Feb 25, 2019

Versions

ConEmu build: 190224 x64
OS version: Windows 10 Pro build 17134 x64
Used shell version (Far Manager, git-bash, cmd, powershell, cygwin, whatever): WSL bash

Problem description

I was using conemu earlier today and got the normal update dialog. I permitted the update. Upon reload, bash doesn't seem to launch. I can launch it from cmd or powershell just fine. Or with the immediately-older conemu, for that matter.

Steps to reproduce

  1. Install conemu 190224
  2. Attempt to launch bash

Actual results

conemu fires up, but there is no output at all.

Expected results

interactive bash shell

Additional files

ConEmu-gui-4156.log
ConEmu-srv-6772.log
ConEmu-con-6772.log

@zbrozek zbrozek changed the title WSL bash doesn't launch with190224 WSL bash doesn't launch with 190224 Feb 25, 2019

@sharpjs

This comment has been minimized.

Copy link

sharpjs commented Feb 25, 2019

Same here. Affects git-bash too.

@kis87988

This comment has been minimized.

Copy link

kis87988 commented Feb 25, 2019

Same here

@mahanmp

This comment has been minimized.

Copy link

mahanmp commented Feb 25, 2019

Same here. Is there any work around you guys found out?

@azriel91

This comment has been minimized.

Copy link

azriel91 commented Feb 25, 2019

The previous version (190217) from https://github.com/Maximus5/ConEmu/releases works.

I upgraded to latest preview, hit this issue, then downgraded

@vp1981

This comment has been minimized.

Copy link

vp1981 commented Feb 25, 2019

Same for cygwin and mingw bash launched by connector. The process in started (I see on bottom line: bash.exe:XXXX) but no output.

@DanteLee

This comment has been minimized.

Copy link

DanteLee commented Feb 25, 2019

Same for this problem after the lastest upgrade 190224. Downgrade to 190217 solve the problem.

@rickrankin

This comment has been minimized.

Copy link

rickrankin commented Feb 25, 2019

I'm seeing the same thing with both Cygwin and MYS2 bash. Bash is clearly running, though, because if I press Ctrl-D, the shell exits.

@aixfox

This comment has been minimized.

Copy link

aixfox commented Feb 25, 2019

+1
Same problem with wsl and git bash (mingw64), but cygwin origin is working.

@simoiu

This comment has been minimized.

Copy link

simoiu commented Feb 25, 2019

Me too :).

@edocevol

This comment has been minimized.

Copy link

edocevol commented Feb 25, 2019

me too...

@SelvarajKaruppusamy

This comment has been minimized.

Copy link

SelvarajKaruppusamy commented Feb 25, 2019

I am using Win10, Opening powershell works for me but git-bash doesn't!

@TimotejFox

This comment has been minimized.

Copy link

TimotejFox commented Feb 25, 2019

Same here for git-bash. And is NOT! a git issue, since git-bash standalone is working.
Downgrading..

@Maximus5

This comment has been minimized.

Copy link
Owner

Maximus5 commented Feb 25, 2019

Yeah, I've noted in Twitter the problem with 24th build

@bbezanson

This comment has been minimized.

Copy link

bbezanson commented Feb 25, 2019

+1 on the issues with git bash on Windows and bash for Windows installed.

It might be a display issue more than anything. Especially for git bash. If I type "exit" the terminal window does close.

@dehrenheim

This comment has been minimized.

Copy link

dehrenheim commented Feb 25, 2019

I had the same experience as @bbezanson in that when I typed exit, it closed my bash window as well.

@Tobbe

This comment has been minimized.

Copy link

Tobbe commented Feb 25, 2019

Thank you @Maximus5 for the quick fix! 🙌 🥇

@ringosham

This comment has been minimized.

Copy link

ringosham commented Feb 25, 2019

190225 regression has this fixed.

@cgaolei

This comment has been minimized.

Copy link

cgaolei commented Feb 26, 2019

Thanks @Maximus5

@simoiu

This comment has been minimized.

Copy link

simoiu commented Feb 26, 2019

Tested, works 👍

@Maximus5 Maximus5 closed this Feb 26, 2019

ConEmu automation moved this from To Do to Done Feb 26, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.
You signed in with another tab or window. Reload to refresh your session. You signed out in another tab or window. Reload to refresh your session.