Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Minimize/Restore doesn't work, also not capturing shortcut key (?) #1871

Open
kmichailg opened this Issue Mar 20, 2019 · 3 comments

Comments

Projects
2 participants
@kmichailg
Copy link

commented Mar 20, 2019

Versions

ConEmu build: 190310 x64
OS version: Windows 10 x64
Used shell version (Far Manager, git-bash, cmd, powershell, cygwin, whatever): MSYS2-zsh oh-my-zsh

Problem description

Minimize/Restore Key not working, pressing minimize on the window isn't also behaving as it should. Note that I am using Cmder with ConEmu. Terminals haven't been closed in a while, restarting them and terminating all instances of the terminals and ConEmu and Cmder doesn't work, problem still persists

Steps to reproduce

  1. Leave terminals running for a long time (?)
  2. Try to minimize using shortcut key.
  3. Try to minimize/restore using window key

Note: Clicking the TSA icon and it works to a degree.

Actual results

Minimize/Restore

Expected results

No action, shortcut key isn't captured (?) and is printed on the terminal/window/text area in focus.

Additional files

ConEmu.xml.txt
HotKeyBug
LogFiles.zip

@Maximus5 Maximus5 added this to To Do in Inspection via automation Mar 20, 2019

@Maximus5 Maximus5 added this to the 190318 milestone Mar 20, 2019

@Maximus5

This comment has been minimized.

Copy link
Owner

commented Mar 30, 2019

  1. First of all I see you have installed two keyboard layouts. And your screenshot shows hotkey Win+' (single quote). But you type in the console the accent char. That's why it is not catched by global hotkeys.
  2. In the attached ConEmu.xml.txt hotkey is defined as Ctrl+accent. Seems like you do use different settings.
@Maximus5

This comment has been minimized.

Copy link
Owner

commented Mar 31, 2019

The actual problem may be with toolbar minimize button. Seems like you have clicked it and there was no reaction, isn't it?

I've added more logs in build 190331. Can you reproduce that in new version? I need new log files.

@Maximus5 Maximus5 modified the milestones: 190325, 190401 Mar 31, 2019

DanaMW added a commit to DanaMW/ConEmu that referenced this issue Apr 2, 2019

Merge remote-tracking branch 'upstream/master'
* upstream/master:
  190331 release files
  190331 Chocolatey and Nuget
  Maximus5gh-1851: Restore contents after return from Alternative screen was broken.
  Internal. Add some notes to RefillConsoleAttributes
  Internal. Fix cl warning
  Maximus5gh-1870: Add switch `/t:<temp dir>` to Setupper.
  Internal. Ensure all vars are initialized
  Maximus5gh-1871: Add some logs to WindowPosChaning.
  Internal. Integer arithmetics
  Maximus5gh-1838: Log start/stop command from Far.exe.
  Maximus5gh-1878: Enable log in `ConEmuC /c` when started from Far.exe.
  Internal. Check for invalid arguments
  Internal. Let CLogFunction log begin/end times
  Internal. Prettify logs
  Internal. Define global ConEmuCD_DLL_3264 macro
  Maximus5gh-1877: Option 'Snap to desktop edges' was broken (regression 663a216).
@kmichailg

This comment has been minimized.

Copy link
Author

commented Apr 11, 2019

  1. First of all I see you have installed two keyboard layouts. And your screenshot shows hotkey Win+' (single quote). But you type in the console the accent char. That's why it is not catched by global hotkeys.

This is weird since I've setup as Win+backtick/accent rather than Win+'. But will look into this.

  1. In the attached ConEmu.xml.txt hotkey is defined as Ctrl+accent. Seems like you do use different settings.

Again, I've not changed it to use Win+', but checking with the keyboard layouts I will test and play around with that new information, if I did unknowingly change it due to me accidentally changing layouts.

The actual problem may be with toolbar minimize button. Seems like you have clicked it and there was no reaction, isn't it?

I've added more logs in build 190331. Can you reproduce that in new version? I need new log files.

If I reproduce this, I will send over the logs. Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.