Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Jump List icons #489

Closed
SergeyVSB opened this issue Dec 25, 2015 · 10 comments
Closed

Jump List icons #489

SergeyVSB opened this issue Dec 25, 2015 · 10 comments
Labels

Comments

@SergeyVSB
Copy link
Contributor

@SergeyVSB SergeyVSB commented Dec 25, 2015

Tasks in Jump List have icon of their primary file, instead of one, specified for task

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Dec 25, 2015

I can't confirm that. Icon was set properly.

@SergeyVSB
Copy link
Contributor Author

@SergeyVSB SergeyVSB commented Dec 25, 2015

Ok, I'll try to reset caches etc.

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Dec 25, 2015

Update your list first.
Doesn't help? Put here settings, screenshots, steps, ...

@SergeyVSB
Copy link
Contributor Author

@SergeyVSB SergeyVSB commented Dec 26, 2015

  1. List works only for x64 GUI at x64 OS (is it as planned?)
  2. But add default tasks adds SDK::VS only in 32bit GUI
  3. Tried to reset explorer's icon cache and reinstall ConEmu, but get the same

Screen: https://yadi.sk/i/ra8LbnXhmVqNg

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Feb 4, 2016

How about latest preview?

Perhaps, fixed since 151126

@SergeyVSB
Copy link
Contributor Author

@SergeyVSB SergeyVSB commented Feb 5, 2016

No, still the same.
I've digged into related *.customdestinations-ms file and extracted LNK file from it. It looks like

Information about shortcut file c:\01_new\jumplists\vs14.lnk:
Target: C:\Program Files\ConEmu\ConEmu64.exe
Arguments: /cmd {SDK::VS 14.0 x86 tools prompt}
Working folder: C:\Program Files\ConEmu
Shortcut key: None
Window: Normal
Comments:
Path to icon: C:\Windows\system32\cmd.exe
icon number: 0

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Feb 5, 2016

Sorry, I still do not understand your issue. Is it all about three points mentioned above?

  1. Why? What? List works everywhere.
  2. There is no "64 bit GUI". What GUI? Studio? It's x86 only, everywhere. x86 argument after vcvarsall.bat? But don't you really think, that ConEmu have to add all supported platforms by vcvarsall? There are seven options! User may clone or change the tasks on their taste.
  3. Why do you talk about icon cache at all? There is "Update Now!" button on the "Task bar" settings page.

At last, about your screenshot. It do not match current build, and conents of the Task do not match expected contents of default Tasks.

At the moment this issue looks like a false report.

@SergeyVSB
Copy link
Contributor Author

@SergeyVSB SergeyVSB commented Feb 5, 2016

Completely reinstalled ConEmu to latest build

  1. [FIXED] If Windows is 64, then list worked only for ConEmu64.exe, not for ConEmu.exe (was wrong before, OK now))
  2. At Windows x64 only 32 bit ConEmu.exe automatically adds SDK::VS (by GUI I've mean conemu gui) - so it's strange
  3. Jumplist icons are displayed wrong (as I show at screenshot upper) - task has custom icon specified in settings (both ways - by /icon or by new_console:C:), but jumplist icon is default icon of task target, not custom. I've think that it is wrong because of Windows icon caches (and so on I try to clear theem), but now i see, that it is wrong specified by ConEmu "Update Now!" button

About screenshot - yes, it is outdated now, but problems are same, so I do not update it

After reinstalling default tasks are

{Shells::TCC}
{Shells::cmd}
{Shells::cmd (Admin)}
{Shells::cmd-32}
{Shells::cmd 64/32}
{Shells::PowerShell}
{Shells::PowerShell (Admin)}
{Bash::CygWin bash}
{Bash::Git bash}
{Bash::MinGW bash}
{Bash::Msys2-64}
{Helper::Show ANSI colors}
{Tools::Chocolatey (Admin)}
{SDK::VS 11.0 x86 tools prompt}
{SDK::VS 14.0 x86 tools prompt}

Last two are auto added only in 32 bit ConEmu

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Feb 5, 2016

I see now. going to fix.

@Maximus5 Maximus5 added the settings label Feb 7, 2016
Maximus5 added a commit that referenced this issue Feb 7, 2016
  * Default Tasks for `SDK::VS *` were not created by ConEmu64.exe.
  * Wrong icon was set for tasks `SDK::VS *` in jump-list.
@SergeyVSB
Copy link
Contributor Author

@SergeyVSB SergeyVSB commented Feb 11, 2016

[FIXED] in 160207 (both icons and default tasks, my fail that they were as single issue), thank you!

@SergeyVSB SergeyVSB closed this Feb 11, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.