Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Newest preview version (150303) ignores default task #63

Closed
kdelmonte opened this issue Mar 5, 2015 · 36 comments
Closed

Newest preview version (150303) ignores default task #63

kdelmonte opened this issue Mar 5, 2015 · 36 comments

Comments

@kdelmonte
Copy link

@kdelmonte kdelmonte commented Mar 5, 2015

I have Gitbash as my default task and it used to worked perfectly until I upgraded to the latest preview version (150303).

@kdelmonte
Copy link
Author

@kdelmonte kdelmonte commented Mar 5, 2015

Update: This only happens when I use the window explorer integration. If I open ConEmu directly it respects the default task.

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Mar 5, 2015

What you have configured, what is expected and what is the current result?

@glen-84
Copy link

@glen-84 glen-84 commented Mar 5, 2015

I have the same issue (my default is set to PowerShell).

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Mar 5, 2015

I have the same questions.

@glen-84
Copy link

@glen-84 glen-84 commented Mar 5, 2015

Aren't those questions already answered?

What you have configured

PowerShell as the default task/shell (http://ctrlv.in/512588)

what is expected

"ConEmu Here" should open PowerShell.

what is the current result

cmd is opened instead.

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Mar 5, 2015

Of course they were not answered, so I was asking.

"New" and "Startup" are different essenses.
Moreover, you are talking about "ConEmu here", that is third setting.

Resume: configure ConEmu properly. Previous behavior was wrong.

@glen-84
Copy link

@glen-84 glen-84 commented Mar 5, 2015

I set the "ConEmu Here" command to "powershell.exe -cur_console:n" and it works now, but IMHO, it should just use the default task/shell.

Thanks.

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Mar 5, 2015

Again.
You've misunderstood options meaning.
"Default task for new console" tells ConEmu to use that task when user press [+] button or corresponding keyboard shortcut. Only!
Startup task may be chosen on Startup setting page. As its name says...

@Maximus5 Maximus5 closed this Mar 5, 2015
@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Mar 5, 2015

One more thing. ConEmu can create many "Here" items. So specifying exact command is highly preferred to avoid inconsistency...

@kdelmonte
Copy link
Author

@kdelmonte kdelmonte commented Mar 5, 2015

Ok, I'll change my configuration but it made more sense the way it worked before. Thanks.

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Mar 5, 2015

How it can make sense? User have to specify "Startup" command/task. The "Default task" was not designed to be used as "Startup" task. Moreover, user can choose to Autosave/restore opened tabs!

@glen-84
Copy link

@glen-84 glen-84 commented Mar 5, 2015

"ConEmu Here" command is: powershell.exe. Startup is set to "Auto save/restore opened tabs". If I use "ConEmu Here" first, and then close and run ConEmu directly, I get:

-cur_console: : The term '-cur_console:' is not recognized as the name of a cmdlet, function, script file, or operable
program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1
+ -cur_console:d:C:\Program Files\ConEmu
+ ~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (-cur_console::String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException



Current directory:
C:\Users\Glen

Command to be executed:
"C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe" "-cur_console:d:C:\Program Files\ConEmu"


ConEmuC: Root process was alive less than 10 sec, ExitCode=1.
Press Enter or Esc to close console...

Did I do something wrong?

@kdelmonte
Copy link
Author

@kdelmonte kdelmonte commented Mar 5, 2015

@Maximus5, how can I configure ConEmu here to open GitBash? Can you provide an example?

@glen-84
Copy link

@glen-84 glen-84 commented Mar 5, 2015

@kdelmonte, set the "ConEmu Here" command to:

"C:\Program Files (x86)\Git\bin\sh.exe" --login -i

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Mar 5, 2015

@glen-84
That is strange. -cur_console must be processed before passing to PowerShell... seems like a bug.

@kdelmonte
`sh.exe --login -i", no?

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Mar 5, 2015

cmd.exe is superfluous for git bash. Moreover it can be harmful in some cases.

@glen-84
Copy link

@glen-84 glen-84 commented Mar 5, 2015

@Maximus5 Yeah I just updated my comment.

@glen-84
Copy link

@glen-84 glen-84 commented Mar 5, 2015

@Maximus5 Are you able to reproduce my issue?

@kdelmonte
Copy link
Author

@kdelmonte kdelmonte commented Mar 5, 2015

@glen-84, @Maximus5 this worked:

"C:\Program Files (x86)\Git\bin\sh.exe" --login -i

Thanks.

@glen-84
Copy link

@glen-84 glen-84 commented Mar 5, 2015

@Maximus5 Here is the config:

<key name="&lt;Startup&gt;" modified="2015-03-05 19:38:32" build="150303">
    <value name="GuiArgs" type="string" data=""/>
    <value name="Active" type="dword" data="00000001"/>
    <value name="Count" type="dword" data="00000001"/>
    <value name="Cmd1" type="string" data="&gt;powershell.exe &quot;-cur_console:d:C:\Program Files\ConEmu&quot;"/>
</key>

I'm guessing the "cur_console" part is not supposed to be quoted?

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Mar 5, 2015

No. Quotations are allowed here.

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Mar 5, 2015

150305

@glen-84
Copy link

@glen-84 glen-84 commented Mar 5, 2015

Nice! Thanks. 😄

@Briahas
Copy link

@Briahas Briahas commented Apr 9, 2015

Hi.
ConEmu x64 150408.x64
If I choose "Auto save/restore oppened tabs", than after restart I'd get:

The syntax of the command is incorrect.


Current directory:
C:\Users\*********

Command to be executed:
"C:\Windows\System32\cmd.exe" /C <Startup>


ConEmuC: Root process was alive less than 10 sec, ExitCode=1.
Press Enter or Esc to close console...

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Apr 9, 2015

@Briahas
Can't reproduce that. Send your ConEmuXml via gist. And, may be, describe steps to get the problem more thoroughly.

@Briahas
Copy link

@Briahas Briahas commented Apr 9, 2015

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Apr 9, 2015

Unbelievable. How <Startup> has got into itself contents? What had you done exactly?

@Briahas
Copy link

@Briahas Briahas commented Apr 10, 2015

I had an old version 13****** and this bug was there at first. After update I thought that it would be fixed. I was wrong.

I dont remember exactly what I did in old version to cose this. I was trying to revert changes, but, as you see - unsuccessfull

Can I fix this by myself?

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Apr 10, 2015

Edit your xml manually. I believe it's impossible to get such situation in current build, so there is nothing to fix. It's already fixed.
ConEmu can't "imagine" what was in your xml before it was broken.

PS. xml or registry - doesn't matter.

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Apr 10, 2015

Actually, the easiest way is to run

ConEmu.exe -detached

@Briahas
Copy link

@Briahas Briahas commented Apr 10, 2015

I dont get it how it'd help me. If it easier to explain in russian - please do.

Maybe it would be easier to re-install ConEmu?

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Apr 10, 2015

Nope. Wait a bit...

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Apr 10, 2015

I see now. There is a conflict with "Minimize on closing last tab".

@Briahas
Copy link

@Briahas Briahas commented Apr 10, 2015

What should I do?

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Apr 10, 2015

Update to latest build.

@Briahas
Copy link

@Briahas Briahas commented Apr 10, 2015

rev.150409
Works.

Right after update - ConEmu close after showing window about "Cant use scrips here" or thmsng like this. Until I enter to Settings, while this window on the screen and turn off "Auto save/restore..."

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
4 participants