Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

PuTTY isn't attached #1899

Closed
Maximus5 opened this issue Jul 31, 2015 · 4 comments
Closed

PuTTY isn't attached #1899

Maximus5 opened this issue Jul 31, 2015 · 4 comments

Comments

@Maximus5
Copy link
Owner

@Maximus5 Maximus5 commented Jul 31, 2015

Originally reported on Google Code with ID 1900

Required information!
OS version: Win8.1 x64
ConEmu version: 150209 x86/x64 alpha
Far version: none

*Bug description*
I have some tasks loading putty sessions, but their windows aren't attached. The putty
window shows up and ConEmu displays the following error message in what was supposed
to be it's tab:
ConEmuC: Root process was alive less than 10 sec, ExitCode=0.
Press Enter or Esc to close console... 

It worked just fine on two other windows 8/8.1 boxes. I've tried upgrading/downgrading
conemu and upgrading putty too. I've attached the logs (taken with /log flag)

Also, I've tried plink, but it has many shortcomings since it isn't designed for interactive
sessions.

*Steps to reproduction*
1. Install putty and create any session with default settings
2. Install conemu, use defaults
3. Create a task for putty using 'putty -new_console -load "<your_session>"'


Reported by andrepnh@yahoo.com.br on 2015-02-10 00:53:13


- _Attachment: [ConEmuC64-size-1768.log](https://storage.googleapis.com/google-code-attachments/conemu-maximus5/issue-1900/comment-0/ConEmuC64-size-1768.log)_ - _Attachment: [ConEmuC-size-2684.log](https://storage.googleapis.com/google-code-attachments/conemu-maximus5/issue-1900/comment-0/ConEmuC-size-2684.log)_ - _Attachment: [ConEmu-gui-5716.log](https://storage.googleapis.com/google-code-attachments/conemu-maximus5/issue-1900/comment-0/ConEmu-gui-5716.log)_ - _Attachment: [ConEmu-input-1768.log](https://storage.googleapis.com/google-code-attachments/conemu-maximus5/issue-1900/comment-0/ConEmu-input-1768.log)_ - _Attachment: [ConEmu-input-2684.log](https://storage.googleapis.com/google-code-attachments/conemu-maximus5/issue-1900/comment-0/ConEmu-input-2684.log)_
@Maximus5
Copy link
Owner Author

@Maximus5 Maximus5 commented Jul 31, 2015

C:\Program Files (x86)\putty
C:\ProgramData\chocolatey\bin\

Specify full path to avoid inconsistence. You have at leat two versions

Reported by ConEmu.Maximus5 on 2015-02-10 07:26:30

  • Status changed: Done
@Maximus5
Copy link
Owner Author

@Maximus5 Maximus5 commented Jul 31, 2015

I've previously uninstalled chocolatey's putty, but at some point a putty.portable package
showed up - and that was the culprit, it's never attached. I've uninstalled it and
now everything works fine with the version at "Program Files (x86)".

Reported by andrepnh@yahoo.com.br on 2015-02-10 11:02:00

@Maximus5
Copy link
Owner Author

@Maximus5 Maximus5 commented Jul 31, 2015

Reported by ConEmu.Maximus5 on 2015-03-23 13:00:40

  • Labels added: putty
@Maximus5
Copy link
Owner Author

@Maximus5 Maximus5 commented Jul 31, 2015

Issue 1951 has been merged into this issue.

Reported by ConEmu.Maximus5 on 2015-03-23 13:01:01

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant
You can’t perform that action at this time.