mcplot-pyqtgraph on Ubuntu 14.04 (and earlier?): python3-pyqtgraph dependency missing #471

Closed
willend opened this Issue May 18, 2017 · 2 comments

Comments

Projects
None yet
3 participants
@willend
Contributor

willend commented May 18, 2017

@farhi reports this issue - and workaround:

  • mcstas-tools-python-mcplot-pyqtgraph-2.4 requires python3-pyqtgraph which is not available under Ubuntu 14.04. Logically, the mcstas-suite-python is not installable.

  • Solution for Ubuntu 14.04:

  • I've installed the python3-pyqtgraph package from the 16.04 xenial repo http://packages.ubuntu.com/xenial/python/python3-pyqtgraph. Then, it is possible to install the full mcstas-suite-python package. And the pyqtgraph front-end works OK.

@AlexDG89

This comment has been minimized.

Show comment
Hide comment
@AlexDG89

AlexDG89 May 27, 2017

Hello,
I'm using Bash on Windows and I found the same problem installing 2.4.
In Windows 10 the bash shell is based on Ubuntu 14.04 so I think can be useful to insert this instructions in the Windows Install page

Hello,
I'm using Bash on Windows and I found the same problem installing 2.4.
In Windows 10 the bash shell is based on Ubuntu 14.04 so I think can be useful to insert this instructions in the Windows Install page

@willend

This comment has been minimized.

Show comment
Hide comment
@willend

willend May 29, 2017

Contributor

Hi @AlexDG89,

Thanks for pointing this out, the website now lists the hint on the Windows Install page also.

Best,
Peter

Contributor

willend commented May 29, 2017

Hi @AlexDG89,

Thanks for pointing this out, the website now lists the hint on the Windows Install page also.

Best,
Peter

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment