Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

McStas v2.5 mcgui on macOS 10.14/10.15: missing template instruments, logo etc. #868

Open
willend opened this issue Oct 10, 2019 · 0 comments
Labels

Comments

@willend
Copy link
Contributor

@willend willend commented Oct 10, 2019

On macOS users may experience a non-functional mcgui, especially when having configured a local preferences file:

Screenshot 2019-10-03 at 17 42 58

A respin of McStas v2.5 addressing this issue was uploaded to http://download.mcstas.org/current/mac/ on October 10th, 2019.

If you experience the issue with an earlier download of McStas 2.5, the situation can be manually corrected by editing your local preferences (.mcstas/2.5/mccode_config.json) file using an editor so that the field "MCCODE_LIB_DIR" looks like this:

"MCCODE_LIB_DIR": "/Applications/McStas-2.5.app/Contents/Resources/mcstas/2.5/"

As mentioned above, the newly uploaded v2.5 app has the issue fixed, so removing any old installation of McStas 2.5 and the local preferences file plus a reinstall should also fix the issue.

@willend willend added the McStas 2.5 label Oct 10, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.