Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fasttrack: No products appear on home page until all Products are manually saved #2237

Open
John-Blair opened this issue Mar 5, 2019 · 4 comments

Comments

Projects
None yet
2 participants
@John-Blair
Copy link

commented Mar 5, 2019

After installing fasttrack 2.7.0 and publishing the entire site. No products appear on the home page - and no errors generated. On research i found that I had to manually save each of the products in the backend before the front end found it.

@timmywiff

This comment has been minimized.

Copy link

commented Mar 11, 2019

I had this problem too. Took me a long time to find the solution.

Have a look at this issue on GitHub.

Once installed, if you cannot see the products on the home page locally (Or on server), then check file permissions for the website folder.

@John-Blair

This comment has been minimized.

Copy link
Author

commented Mar 11, 2019

Thanks for the reply - i haven't done a fresh install to check it out.
Which folder did you change the permissions on - as the products are stored in the db - was it the app_data folder which contains the published umbraco data in umbraco.config?
Where is the fasttrack code that causes a new product to be published in umbraco?

The following may be of help to other users.

I use IIS and applicationpoolidentity - here is how to change permissions for that user:

https://support.pkware.com/plugins/servlet/mobile#content/view/7471153

I also ran into permission problems accessing localdb via iis and the following is how i resolved that:
set setProfileEnvironment="true" in
"C:\Windows\System32\inetsrv\Config\applicationHost.config" i.e.

Thanks.

@timmywiff

This comment has been minimized.

Copy link

commented Mar 11, 2019

I'm very new to Umbraco and not an experienced .NET developer. However, to answer your first question, I believe I gave IUSR all permissions except Full Control on the root directory of the project.

I'm not sure where the Fasttrack code is that causes a new product to be published in Umbraco.

I hope this helps.

@John-Blair

This comment has been minimized.

Copy link
Author

commented Mar 11, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.