Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Is MetaMask down or just me? #6519

Closed
marsrobertson opened this issue Apr 26, 2019 · 24 comments

Comments

Projects
None yet
@marsrobertson
Copy link

commented Apr 26, 2019

Tried two different computers, on both MetaMask keep hanging:

Screenshot 2019-04-26 at 12 40 39

@mouragio

This comment has been minimized.

Copy link

commented Apr 26, 2019

Same here...

@fateevv

This comment has been minimized.

Copy link

commented Apr 26, 2019

The same problem.

@wnz99

This comment has been minimized.

Copy link

commented Apr 26, 2019

same, I had to downgrade to 6.3.2.

@jeschild1

This comment has been minimized.

Copy link

commented Apr 26, 2019

same here. it was working fine several hours ago... and then kaput!

@marsrobertson

This comment has been minimized.

Copy link
Author

commented Apr 26, 2019

@wnz99 how do you downgrade?

Manually Load Unpacked Extension?

https://github.com/MetaMask/metamask-extension/blob/develop/docs/add-to-chrome.md

@wnz99

This comment has been minimized.

Copy link

commented Apr 26, 2019

@marsrobertson yes, I did it manually. Make sure you have your private keys to restore the accounts. Not sure if there is a way to restore the accounts by copying the addon config from one version to the other.

@tlatldms

This comment has been minimized.

Copy link

commented Apr 26, 2019

Same here! Loading Forever. Are you doing well now?

@Droopy78

This comment has been minimized.

Copy link

commented Apr 26, 2019

Currently, I'm only seeing spotty Metamask uptime on Rinkeby and Mainnet. Browser doesn't matter, and tried from multiple computers and locations. Have to completely remove metamask from Firefox and Chrome, and then reinstall to get rid of loading indicator. Now the loading indicator sometimes clears after minutes, so maybe it's a high load/traffic issue (currently I'm back to 10+ mins of waiting).

@robsecord

This comment has been minimized.

Copy link

commented Apr 26, 2019

Same issue - forever loading.. Chrome, Brave, Firefox..
Console for the MM window shows:
Screen Shot 2019-04-26 at 9 57 36 AM

@mouragio

This comment has been minimized.

Copy link

commented Apr 26, 2019

I have completely removed metamask from Chrome and reinstalled/reconnected.
Now its working again...

@junzhli

This comment has been minimized.

Copy link

commented Apr 26, 2019

Here is the point I found out:
The website which serves contract's method known signature is down now...
It makes Metamask hanging until the server responds with error code 503 (service unavailable)

https://www.4byte.directory/api/v1/signatures/?hex_signature=0x0121b93f --> takes too much time to respond

Screen Shot 2019-04-26 at 10 48 43 PM

Any idea to resolve this issue? Very annoying...

@perich

This comment has been minimized.

Copy link

commented Apr 26, 2019

Yup, looks like their entire site is down (for me at least).

curl https://www.4byte.directory

<!DOCTYPE html>
	<html>
	  <head>
		<meta name="viewport" content="width=device-width, initial-scale=1">
		<meta charset="utf-8">
		<title>Application Error</title>
		<style media="screen">
		  html,body,iframe {
			margin: 0;
			padding: 0;
		  }
		  html,body {
			height: 100%;
			overflow: hidden;
		  }
		  iframe {
			width: 100%;
			height: 100%;
			border: 0;
		  }
		</style>
	  </head>
	  <body>
		<iframe src="//www.herokucdn.com/error-pages/application-error.html"></iframe>
	  </body>
	</html>%

Interestingly, some of my teammates in different regions can still use MetaMask. But for several of us, it's stuck on the spinning pinwheel because of this broken dependency.

@tlatldms

This comment has been minimized.

Copy link

commented Apr 26, 2019

@wnz99 Hello. How did you downgrade it? I cannot find metamask-plugin folder. I downloaded 6.3.2 version from its commit log but cannot fix it to be uploaded on chrome extension.

@wnz99

This comment has been minimized.

Copy link

commented Apr 26, 2019

@tlatldms get the zip from here: https://github.com/MetaMask/metamask-extension/releases/tag/v6.3.2

Unzip it.

Then follow instructions at https://github.com/MetaMask/metamask-extension/blob/develop/docs/add-to-chrome.md

You just have to select the folder where you have unzipped the extension files.

Remember to backup your private keys first and disable the current add-on first.

Anyway, some users have reported that reinstalling v6.4.0 solves the problem.

@topocount

This comment has been minimized.

Copy link

commented Apr 26, 2019

@marsrobertson it's not down it just takes a really long time to resolve function information if it's not stored on the parity function registry. I've logged #6514 to address the root cause of this issue.

@owocki

This comment has been minimized.

Copy link

commented Apr 26, 2019

i'm having the same issue here too #6520

@danlipert

This comment has been minimized.

Copy link

commented Apr 26, 2019

I also observed this today - after disabling and re-enabling the extension in chrome a few times, I was able to get it to work

@frncscdf

This comment has been minimized.

Copy link

commented Apr 26, 2019

Same here.

@loriopatrick

This comment has been minimized.

Copy link

commented Apr 26, 2019

Is there a community QA team to green light releases? #6525

@bdresser

This comment has been minimized.

Copy link
Member

commented Apr 26, 2019

This is fixed in 6.4.1, live on Firefox already, should be live on Chrome momentarily

@perich

This comment has been minimized.

Copy link

commented Apr 26, 2019

thanks for the quick turnaround on a Friday

@bdresser

This comment has been minimized.

Copy link
Member

commented Apr 26, 2019

Hey folks, still pending review on Chrome. It usually doesn't take this long – seems like they've added an additional review step.

Firefox has updated and if you need this on Chrome in the meantime you can download v6.4.1 from our Releases page. Sorry for the trouble and thanks your for patience.

@onxy2019

This comment has been minimized.

Copy link

commented Apr 27, 2019

how can I reconnect to smart contract after reinstalling Metamask?

@bdresser

This comment has been minimized.

Copy link
Member

commented Apr 29, 2019

Chrome is up-to-date. Closing this via #6521

We're aware of function names showing up as [undefined] which will be fixed in #6524

@onxy2019 I'm not sure I understand your question – reach out to support@metamask.io and we'll help you over there!

@bdresser bdresser closed this Apr 29, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.