Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

_includePaths is not iterable in Meteor 1.8 #289

Open
derwaldgeist opened this issue Apr 5, 2019 · 8 comments
Open

_includePaths is not iterable in Meteor 1.8 #289

derwaldgeist opened this issue Apr 5, 2019 · 8 comments

Comments

@derwaldgeist
Copy link

@derwaldgeist derwaldgeist commented Apr 5, 2019

  • Feature request
  • Bug report
  • Question

meteor version: 1.8.0.2
fourseven:scss version: 4.10.0

I'm trying to reference a stylesheet in the reywood:bootstrap3-sass package. This worked in my apps running on previous versions, but with Meteor 1.8.0.2, when I try this:

@import '{reywood:bootstrap3-sass}/assets/stylesheets/bootstrap/variables';

I get this error message:

 While processing files with fourseven:scss (for target web.browser.legacy):
   /client/stylesheets/main.scss: Scss compiler error: Error: _includePaths is not iterable
   on line 12 of globals
   from line 3 of {}/client/stylesheets/main.scss
   >> @import '{reywood:bootstrap3-sass}/assets/stylesheets/bootstrap/variables';
   
   --------^

This does not seem to be related to #273, since my SCSS files are located in a Meteor package, not in an NPM package.

@ajsingh4

This comment has been minimized.

Copy link

@ajsingh4 ajsingh4 commented Apr 17, 2019

Coming across the same issue but with Meteor 1.8.1.

@Philip-Nunoo

This comment has been minimized.

Copy link

@Philip-Nunoo Philip-Nunoo commented Apr 25, 2019

Same Issue

@RTSchriner

This comment has been minimized.

Copy link

@RTSchriner RTSchriner commented May 7, 2019

Anyone find a fix for this?

@sebakerckhof

This comment has been minimized.

Copy link
Collaborator

@sebakerckhof sebakerckhof commented May 7, 2019

Do you guys have a scss-config.json file?

@ajsingh4

This comment has been minimized.

Copy link

@ajsingh4 ajsingh4 commented May 7, 2019

@nikhilgoswami

This comment has been minimized.

Copy link

@nikhilgoswami nikhilgoswami commented Nov 8, 2019

Correct answer as of Meteor 1.8 is
in terminal
cd import folder in project root
ln -s ../node_modules/bootstrap-scss \note path to package not individual file;
then in @import '../import/bootstrap-scss/assets/stylesheets/_bootstrap.scss';
Hope that will be it

@Adoyle2014

This comment has been minimized.

Copy link

@Adoyle2014 Adoyle2014 commented Nov 10, 2019

What is the fix for working in windows. I get an error saying 'ln' is not a recognized cmdlet, function, script file, or operable program.

@nikhilgoswami

This comment has been minimized.

Copy link

@nikhilgoswami nikhilgoswami commented Nov 15, 2019

@Adoyle2014 For windows I guess you need to install bash terminal and run command on terminal

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
7 participants
You can’t perform that action at this time.