Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Graphical glitches over HDMI when Amiga switches between resolution modes #4

Closed
c0d3h4x0r opened this issue Apr 21, 2019 · 1 comment

Comments

2 participants
@c0d3h4x0r
Copy link

commented Apr 21, 2019

This is most apparent when switching from an interlaced resolution mode to a non-interlaced resolution mode, and vice-versa. From anecdotal comparisons with other MiSTer users, it sounds like this may only impact the HDMI output.

Example repro:

  1. Set Workbench to use "High-Res Interlaced" mode.
  2. Launch ProTracker, which opens in a non-interlaced mode.
  3. Now use the z-ordering widget in the upper-right corners of Workbench and ProTracker to repeatedly switch between them.

Result: Very noticeable full-screen graphical artifacts (interleaved lines, momentary wrong-scaled image of the mode being switches away from, etc) as observed in the attached slow-motion video clips.

Expect: No graphical glitches when switching resolution modes.

Minimig_resolution_switch_glitch_videos.zip

@sorgelig

This comment has been minimized.

Copy link
Member

commented Apr 21, 2019

It's how Scaler works. It's not expecting dynamic resolution switch. And it's not related to Minimig.
You may reach the Scaler developer (Atari forum) and ask if it possible to fix.

Not a Minimig issue.

@sorgelig sorgelig closed this Apr 21, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.