FAQ

Harrison W edited this page Sep 12, 2016 · 7 revisions

Q: How to setup a Raspberry Pi to run MagicMirror²

A: Check this extended tutorial: https://forum.magicmirror.builders/topic/236/complete-setup-tutorial/

Q: Which Raspberry Pi versions are supported?

A: Currently, MagicMirror² supports the Raspberry Pi 2 and Raspberry Pi 3. For a Raspberry Pi 1, you can run MagicMirror² in serveronly mode. For more information, please follow the instructions on the setup page.

Q: How do I update my MagicMirror² installation?

A: Perform the following command on your command line: cd ~/MagicMirror && git pull

Q: I'm having problems with my config.js but can't find the issue ...

A: Paste your config into http://jshint.com and you'll probably find out soon!