New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

NAV App Setting table is not cleaned up with Sync-NAVApp Mode=Clean #4166

Closed
ajkauffmann opened this Issue Nov 5, 2018 · 1 comment

Comments

Projects
None yet
3 participants
@ajkauffmann
Contributor

ajkauffmann commented Nov 5, 2018

The setting to enable or disable an outgoing HTTP call from a sandbox is stored in the NAV App Setting table.

However, this setting is not cleaned (the record is not removed) when you completely remove the app.
Both options to clean data do not remove the setting from the NAV App Setting table:

  • UnInstall-NAVApp -DoNotSaveData
  • Sync-NAVApp - Mode Clean

Also the option schemaUpdateMode = Recreate in the launch.json does not remove the setting.

@atoader atoader self-assigned this Nov 6, 2018

@ALGitHubBot ALGitHubBot added this to the November 2018 milestone Nov 14, 2018

@ALGitHubBot

This comment has been minimized.

Member

ALGitHubBot commented Nov 14, 2018

The fix for this issue has been checked in to the master branch. It will be available in the bcinsider.azurecr.io/bcsandbox-master Docker image starting from build number 25828.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment