New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Could not load file or assembly 'stdole' or one of its dependencies #1223

Closed
inornos opened this Issue Sep 13, 2016 · 3 comments

Comments

Projects
None yet
3 participants
@inornos

inornos commented Sep 13, 2016

My Bot Not Working Because of this error after publish on my domain Could not load file or assembly 'stdole' or one of its dependencies. Strong name signature could not be verified. The assembly may have been tampered with, or it was delay signed but not fully signed with the correct private key. (Exception from HRESULT: 0x80131045)

Please help

image

@willportnoy

This comment has been minimized.

Show comment
Hide comment
@willportnoy

willportnoy Sep 13, 2016

Member

I don't believe the Bot Framework has a "stdole.dll" file, but if you want to prevent ASP.NET from opening the file while compiling the contents of the bin directory, you can use a solution like this (different cause, possibly the same solution):

http://blog.willportnoy.com/2011/07/badimageformatexception-with-aspnet-and.html

Member

willportnoy commented Sep 13, 2016

I don't believe the Bot Framework has a "stdole.dll" file, but if you want to prevent ASP.NET from opening the file while compiling the contents of the bin directory, you can use a solution like this (different cause, possibly the same solution):

http://blog.willportnoy.com/2011/07/badimageformatexception-with-aspnet-and.html

@dandriscoll

This comment has been minimized.

Show comment
Hide comment
@dandriscoll

dandriscoll Sep 14, 2016

Member

You can also use the Fusion log to get more detail on assembly load errors. https://msdn.microsoft.com/en-us/library/e74a18c4(v=vs.110).aspx

Member

dandriscoll commented Sep 14, 2016

You can also use the Fusion log to get more detail on assembly load errors. https://msdn.microsoft.com/en-us/library/e74a18c4(v=vs.110).aspx

@dandriscoll

This comment has been minimized.

Show comment
Hide comment
@dandriscoll

dandriscoll Sep 16, 2016

Member

Closing this as it's not really related to the Bot Framework. There are some suggestions above but since it's not our area of expertise, I don't think we'll be able to help much past that. Please open a new issue if you find there is something specific to Bot Framework we need to address. Thanks

Member

dandriscoll commented Sep 16, 2016

Closing this as it's not really related to the Bot Framework. There are some suggestions above but since it's not our area of expertise, I don't think we'll be able to help much past that. Please open a new issue if you find there is something specific to Bot Framework we need to address. Thanks

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment