New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

GLIBC not found error for binary installation #731

Closed
funguy74 opened this Issue Aug 2, 2016 · 1 comment

Comments

Projects
None yet
1 participant
@funguy74

funguy74 commented Aug 2, 2016

I tried binary installation (both 1.6 and 1.5 versions) in redhat linux but I got following errors when I invoke cntk:

cntk: /lib64/libc.so.6: version GLIBC_2.14' not found (required by cntk) cntk: /lib64/libc.so.6: versionGLIBC_2.17' not found (required by /home/sr3/jaey1.kim/binary2/cntk/cntk/lib/libcntkmath.so)
cntk: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/sr3/jaey1.kim/binary2/cntk/cntk/lib/libcntkmath.so

Firstly, it's strange that both 2.14 and 2.17 version is needed. Furthermore, library name is same for both versions and I don't know how to provide two different versions with same name.

Firstly, I tried to include GLIBC_2.14 in my bashrc:

export LD_LIBRARY_PATH=/apps/glibc/RHEL6.4/glibc-2.14.1/lib/$LD_LIBRARY_PATH

Then, I got following message:

cntk: /apps/glibc/RHEL6.4/glibc-2.14.1/lib/libc.so.6: version `GLIBC_2.17' not found (required by /home/sr3/jaey1.kim/binary2/cntk/cntk/lib/libcntkmath.so

CNTK is still asking 2.17 glibc. Is there any idea?

@funguy74

This comment has been minimized.

Show comment
Hide comment
@funguy74

funguy74 Aug 4, 2016

It comes from old version of glibc libary. I resolved it with glibc version higher than 2.17.

funguy74 commented Aug 4, 2016

It comes from old version of glibc libary. I resolved it with glibc version higher than 2.17.

@funguy74 funguy74 closed this Aug 4, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment