New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Popup Menu button issue #880

Closed
ali-siddiqui opened this Issue Aug 19, 2017 · 3 comments

Comments

Projects
None yet
3 participants
@ali-siddiqui

ali-siddiqui commented Aug 19, 2017

The first time I use the popup menu button it works fine. However, once I close the popup menu and try to activate it again it doesn't work and no other input works. Anyone else get this problem? Is it an easy fix?

@kewlniss

This comment has been minimized.

Show comment
Hide comment
@kewlniss

kewlniss Aug 30, 2017

There is an "easy" fix, but I'm not sure what else it breaks. One of my members found this a while back and I figured out the "fix", but forgot to raise an issue here for it.

In the DehydrationDeactivation.cs file under Input/Tests/Scripts the OnStateExit needs to be changed back to OnStateEnter. It was modified sometime in mid December if I remember correctly.

I believe this just affects the animation, but I'm not sure what else that change may break.

The change that caused the popup to fail to reopen was #401

kewlniss commented Aug 30, 2017

There is an "easy" fix, but I'm not sure what else it breaks. One of my members found this a while back and I figured out the "fix", but forgot to raise an issue here for it.

In the DehydrationDeactivation.cs file under Input/Tests/Scripts the OnStateExit needs to be changed back to OnStateEnter. It was modified sometime in mid December if I remember correctly.

I believe this just affects the animation, but I'm not sure what else that change may break.

The change that caused the popup to fail to reopen was #401

@StephenHodgson

This comment has been minimized.

Show comment
Hide comment
@StephenHodgson

StephenHodgson Aug 30, 2017

Collaborator

@kewlniss I'll take a look, thanks for the report.

Collaborator

StephenHodgson commented Aug 30, 2017

@kewlniss I'll take a look, thanks for the report.

@kewlniss

This comment has been minimized.

Show comment
Hide comment
@kewlniss

kewlniss Aug 30, 2017

No problem, @StephenHodgson. Sorry I didn't bring this up back in April when it was brought to my attention. Here's a video just I uploaded that includes a clip from the Live Q&A where I talked about the issue in case it helps.
https://www.youtube.com/watch?v=zBe4GpE-dTY

kewlniss commented Aug 30, 2017

No problem, @StephenHodgson. Sorry I didn't bring this up back in April when it was brought to my attention. Here's a video just I uploaded that includes a clip from the Live Q&A where I talked about the issue in case it helps.
https://www.youtube.com/watch?v=zBe4GpE-dTY

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment