New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

OS build 17134.5 Stop Code: SYSTEM_THREAD_EXCEPTION_NOT_HANDLED FLTMGR.SYS #3148

Closed
mattmon1 opened this Issue May 4, 2018 · 11 comments

Comments

Projects
None yet
6 participants
@mattmon1
Copy link

mattmon1 commented May 4, 2018

I used the insider's program to upgrade some W10 machines:
From: Version 1803 (OS build 17.134.1) - RTM
To: Version 1803 (OS build 17134.5) - GA

After upgrading, running ubuntu.exe from a command window with administrator perms yields:
StdOut: Performing one-time upgrade of the Windows Subsystem for Linux file system for this distribution.
Machine:
Stop Code: SYSTEM_THREAD_EXCEPTION_NOT_HANDLED
What Failed: FLTMGR.SYS

I'm getting this error on two different machines. Just reaching out to see if others are experiencing the same issue and if there is a fix pending?

Thanks,
Matt

@Brian-Perkins

This comment has been minimized.

Copy link
Collaborator

Brian-Perkins commented May 4, 2018

@mattmon1, do you have Bitdefender installed? There was a similar issue reported here.

@mattmon1

This comment has been minimized.

Copy link
Author

mattmon1 commented May 4, 2018

@Biswa96 Per WSL post instructions, a mini-dump has been sent to secure@microsoft.com.

@mattmon1

This comment has been minimized.

Copy link
Author

mattmon1 commented May 4, 2018

@Brian-Perkins I do have Bitdefender installed on one of the machines.

For #2982:
I checked windows features to confirm that the WSL feature was still checked.
I unchecked WSL, rebooted, checked WSL and rebooted.
Afterwards, I still get BSOD when running Ubuntu.exe

Unlike #2982, my BSOD failure is in FLTMGR.SYS not HBFLT.SYS.

FLTMGR.SYS is the Microsoft Filesystem Filter Manager. AFAICT it is not related to Bitdefender. Please let me know if my understanding is inaccurate.

@Brian-Perkins

This comment has been minimized.

Copy link
Collaborator

Brian-Perkins commented May 4, 2018

@mattmon1 -- received the mini-dump. It still looks like BitDefender but for future reference this time the faulting driver is ignis.sys

@mluypaert

This comment has been minimized.

Copy link

mluypaert commented May 7, 2018

+1, same problem here after updating to Windows 1803 (OS build 17134.1). After uninstalling Bitdefender (Endpoint security tools here) Ubuntu on windows works, but as soon as I installed Bitdefender again, the blue screens are back.

@mattmon1

This comment has been minimized.

Copy link
Author

mattmon1 commented May 7, 2018

Attached are my test findings. In short, the issue seems due to filter driver collisions between W10, SnagIt and Bitdefender.

Uninstalled Bitdefender
Ran administrator command prompt & executed ubuntu.exe - ASW
Installed Bitdefender and rebooted(required)
Ran administrator command prompt & executed ubuntu.exe - ASW

Bitdefender reported need to reboot for engine update and rebooted
Bitdefender enabled Bitdefender Firewall when Skype for business opened after reboot
Bitdefender installed Engine Update 6.2.36.1014 -> 7.75907(11861612)
Ran administrator command prompt & executed ubuntu.exe - ASW
Ran Check for Bitdefender updates - Updated to 7.75908(11862372)
Ran check for Bitdefender updates - No update available
Ran administrator command prompt & executed ubuntu.exe - ASW

Installed SnagIt & Rebooted
Ran administrator command prompt & executed ubuntu.exe - Blue Screen FLTMGR.SYS
Uninstalled SnagIt & Rebooted
Ran administrator command prompt & executed ubuntu.exe - Blue Screen FLTMGR.SYS
Uninstalled Bitdefender
Ran administrator command prompt & executed ubuntu.exe - ASW

Installed Bitdefender and rebooted
Bitdefender reported need to reboot for engine update and rebooted
Bitdefender enabled Bitdefender Firewall when Skype for business opened after reboot
Bitdefender installed Engine Update 6.2.36.1014 -> Updated to 7.75908(11862372)
Ran administrator command prompt & executed ubuntu.exe - ASW
Running Bitdefender Full Scan - In progress

@mattmon1

This comment has been minimized.

Copy link
Author

mattmon1 commented May 8, 2018

Uninstalled Ubuntu and disabled the WSL feature. After reboot, Bitdefender and SnagIt both perform fine - no Blue screens. My plans are to use Cygwin for my Linux needs on W10 and migrate back to WSL Ubuntu when it has stabilized. My hopes are that the WSL team can resolve this issue soon.

@mattmon1

This comment has been minimized.

Copy link
Author

mattmon1 commented May 8, 2018

The SYSTEM_THREAD_EXCEPTION_NOT_HANDLED Blue screen was also encountered after 1803 upgrade on a W10 machine running Windows defender and firewall, where Bitdefender and SnagIt were not installed. This same machine, earlier, experienced rolling exceptions during WSL ubuntu command invocations (#2931) when defender/firewall were actively scanning. I worked around the rolling
exceptions issue per the workaround documented in #2931.

@DamienGombaultRecia

This comment has been minimized.

Copy link

DamienGombaultRecia commented May 18, 2018

Hi.
I have opened a ticket on the Bitdefender support :

Thank you for reaching Bitdefender Enterprise Support.
We are aware of this issue and it will be resolved on the 24th of May when the new product update will be released.

@DamienGombaultRecia

This comment has been minimized.

Copy link

DamienGombaultRecia commented May 23, 2018

Hi.
The problem is fixed with the Bitdefender Endpoint Security Tools 6.6.1.36 version.
This version is available in the Fast Ring channel.
The update should reach the Slow Ring channel soon.

@heepdog

This comment has been minimized.

Copy link

heepdog commented May 24, 2018

Received Bitdefender update this morning and can confirm it was fixed.

@benhillis benhillis closed this May 24, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment