New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Configure an agent for both build and deployment #1346

Closed
tolgabalci opened this Issue Dec 27, 2017 · 1 comment

Comments

Projects
None yet
2 participants
@tolgabalci

tolgabalci commented Dec 27, 2017

Have you try trouble shooting doc?
Yes

Agent version and platform
Version of your agent? 2.126.0

OS of the machine running the agent? OSX/Windows/Linux...
Windows Server 2012 R2 standard

VSTS type and version
VisualStudio.com

Issue

I would like configure an agent for both build and deployment. Is this possible? If so how? What would the config.cmd look like to accomplish this?

When I run:
.\config.cmd --deploymentgroup --deploymentgroupname "MY DEPLOY" --pool "MY POOL" --agent "agent1"

The [--pool "MY POOL"] options seems to be ignored. The agent appears under Deployment Groups, but not my "MY POOL" Agent Queue.

If I remove [--deploymentgroup --deploymentgroupname "TIM DEV"], then the agent appears under my "MY POOL" Agent Queue just fine. (Obviously, though it is not listed in the Deployment Groups any longer.)

@bryanmacfarlane

This comment has been minimized.

Member

bryanmacfarlane commented Jan 5, 2018

No, each instance of the agent is configured build or deployment agent. That's why we allow SxS instances on a machine. They are xcopy, unzip, configure in two SxS directories.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment