New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

microsoft/bcsandbox missing data #228

Closed
ernestasju opened this Issue Jul 9, 2018 · 8 comments

Comments

Projects
None yet
6 participants
@ernestasju
Copy link

ernestasju commented Jul 9, 2018

I have noticed that Docker image for Business Central has no data in it.
Is this intended?

Docker image version: 12.2.22932.23097.

Database: FinancialsW1.
Company: My Company.

Command for creating the container:

docker run -it --name mytest -h mytest -m 4g -e accept_eula=Y microsoft/bcsandbox
@lhtan-dev

This comment has been minimized.

Copy link

lhtan-dev commented Jul 9, 2018

Creating a new company starting with CRONUS name and selecting sample data seems to do the trick. However it installs the GB evaluation data. Anyone knows how to select other country evaluation data?

@f4nx

This comment has been minimized.

Copy link

f4nx commented Jul 22, 2018

I have the same problem as @ernestasju and tried your suggested trick but it didn't work because the rapidstart packages weren't provided. Could you please explain? Thank you @lhtan-dev

@lhtan-dev

This comment has been minimized.

Copy link

lhtan-dev commented Jul 22, 2018

Hi @f4nx , sharing the screenshots of the steps I took. Is it similar?
demo data issue - 1
demo data issue - 2
demo data issue - 3

@f4nx

This comment has been minimized.

Copy link

f4nx commented Jul 22, 2018

Hi, I guess the language in the settings on the web client was an issue. The package has been imported successfully. It is like you said the GB version. Thank you.

@freddydk

This comment has been minimized.

Copy link
Contributor

freddydk commented Aug 13, 2018

If you use microsoft/bcsandbox:base, then you will get w1 demo data.
base is the foundation of all languages and will contain the on-prem w1 db.
master insider builds with :w1 will contain the saas demo data.

@freddydk freddydk closed this Aug 13, 2018

@xgaronnat

This comment has been minimized.

Copy link

xgaronnat commented Sep 5, 2018

Hi all,

On a fresh tenant created today with template bcinsider.azurecr.io/bcsandbox-master:base, I get this (license ?) error :

_You do not have the following permissions on CodeUnit Create Demonstration Data: Execute.

To view details about your permissions, see the Effective Permissions page. To report a problem, refer to the following server session ID: '30'._

Any idea to solve this ?

@naveksa

This comment has been minimized.

Copy link

naveksa commented Nov 14, 2018

We have an issue on missing Manufacturing data.
We are using an Azure-server with bcsandbox and build a docker sandbox with the following ps-code:

install-module navcontainerhelper -force

$accept_eula = $true
$containername = 'NAVEKSA'
$navdockerimage = 'microsoft/bcsandbox:dk'
$appbacpacuri = ''
$tenantbacpacuri = ''
$additionalParameters = @()
if ($appbacpacuri -ne '' -and $tenantbacpacuri -ne '') {
$additionalParameters = @("--env appbacpac=""$appbacpacuri""","--env tenantBacpac=""$tenantbacpacuri""")
}

$credential = get-credential -UserName $env:USERNAME -Message "Using Windows Authentication. Please enter your Windows credentials."
New-NavContainer -accept_eula:$accept_eula -containername $containername
-auth Windows -Credential $credential
-includeCSide -alwaysPull
-doNotExportObjectsToText -usessl:$false
-updateHosts -assignPremiumPlan
-shortcuts Desktop -imageName $navdockerimage
-additionalParameters $additionalParameters `
-licenseFile 'C:\Naveksa\nav_2018_licens_nov2018.flf'

Setup-NavContainerTestUsers -containerName $containername -password $credential.Password

We get a full environment with basic Cronus demo-data (Customers, items etc.) but no manufacturing data.
No Work Centers, no routings, no prod.BOMs.

The Azure-server was created with Assign Premium Plan = Yes
The New-NavContainer includes the parameter -assignPremiumPlan
and we have selected the UserExperience = Premium.

We have tried with the us-version as well, that is
$navdockerimage = 'microsoft/bcsandbox:us'
but with same result.

Please advice.

@naveksa

This comment has been minimized.

Copy link

naveksa commented Nov 14, 2018

Sorry, did not observe that this issue was closed.
Comments above moved to new issue #288

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment