Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

After clicking "verify", the info "verifying" keeps showing w/o more hints #137

Closed
mybayern1974 opened this issue Mar 14, 2017 · 7 comments

Comments

@mybayern1974
Copy link

commented Mar 14, 2017

I was using the provided app.ino. As a beginner,I'm puzzled and don't know whether things are correct or failed when seeing the "Verifying" info keep showing w/o any more hints. Attached the screenshot.
keep_verifying

@akaroml akaroml added this to the On Deck milestone Mar 14, 2017
@robotdad

This comment has been minimized.

Copy link
Member

commented Mar 14, 2017

This is #141

Agree if this happens, e.g. arduino_debug exits without finishing something should be reported though.

@akaroml akaroml added the blocking label Mar 28, 2017
@akaroml akaroml modified the milestones: Sprint 5, On Deck Apr 10, 2017
@akaroml

This comment has been minimized.

Copy link
Member

commented Apr 10, 2017

Any updates? @yaohaizh

@yaohaizh

This comment has been minimized.

Copy link
Contributor

commented Apr 10, 2017

This is the same issue of the upload error of timeout? I think we should set the default arduino.logLevel to verbose for better diagnostic.

@akaroml akaroml modified the milestones: Sprint 6, Sprint 5 Apr 11, 2017
@akaroml

This comment has been minimized.

Copy link
Member

commented Apr 11, 2017

After further investigation, this turns out to be the default behavior of Arduino IDE. When using the default log level 'info', Arduino does not print that many logs. In our case, the 'Timeout' logs are invisible due to this. So you see the build process hanging but it's actually running.
One way to improve this is to turn on the verbose log level by default. But that would introduce lots of noise. It not a blocking issue for the first release so I put it in the next release to revisit.

@liydu liydu added arduino-cli and removed external labels Feb 9, 2018
@liydu

This comment has been minimized.

Copy link
Member

commented Feb 9, 2018

We may wait to see what arduino-cli can provide improvements on this.

@liydu liydu modified the milestones: Sprint 6, Sprint 133 Feb 9, 2018
@czgtest czgtest added the enhancement label Mar 7, 2018
@czgtest

This comment has been minimized.

Copy link
Collaborator

commented Mar 7, 2018

@mybayern1974 have you got this issue solved?

@lirenhe lirenhe removed this from the Sprint 133 milestone Mar 16, 2018
@Sneezry Sneezry referenced this issue Apr 2, 2018
7 of 7 tasks complete
@czgtest

This comment has been minimized.

Copy link
Collaborator

commented May 14, 2018

After click "verify", user can see the status of tool bar :"Arduino:Verifing"

image

@czgtest czgtest closed this May 14, 2018
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
9 participants
You can’t perform that action at this time.