New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update nvmrc to node 8 #67183

Merged
merged 1 commit into from Jan 28, 2019

Conversation

Projects
None yet
2 participants
@dvkndn
Copy link
Contributor

dvkndn commented Jan 27, 2019

As noted in the wiki, node's version should be larger than 8.12 so 8.9.2 will not work.

In fact, I think we only need to define the target version as 8 so we can have the latest version that satisfies the requirement (>= 8.12.0, < 9.0.0). At the time of writing it is 8.15 which works perfectly fine (installed + watch + run successfully).

Update nvmrc
As noted in [the wiki](https://github.com/Microsoft/vscode/wiki/How-to-Contribute#prerequisites) node's version should be larger than 8.12 so 8.9.2 will not work.

In fact, I think we only need to define the target version as `8` so we can have the latest version that satisfies the requirement (`>= 8.12.0, < 9.0.0`). At the time of writing it is `8.15` which works perfectly fine (install + watch + run).

@joaomoreno joaomoreno merged commit b1bf810 into Microsoft:master Jan 28, 2019

2 checks passed

VS Code #20190127.4 succeeded
Details
license/cla All CLA requirements met.

@joaomoreno joaomoreno added this to the December/January 2019 milestone Jan 28, 2019

@joaomoreno

This comment has been minimized.

Copy link
Member

joaomoreno commented Jan 28, 2019

Thanks!

@dvkndn dvkndn deleted the dvkndn:patch-1 branch Jan 28, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment