Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

wsl2 : docker containers can't access internet #422

Closed
nicolasdelvat opened this issue Jun 15, 2019 · 5 comments
Closed

wsl2 : docker containers can't access internet #422

nicolasdelvat opened this issue Jun 15, 2019 · 5 comments

Comments

@nicolasdelvat
Copy link

@nicolasdelvat nicolasdelvat commented Jun 15, 2019

I just installed the new build (18917) to test wsl2 with docker.
image
image

All commands calling the network in containers seems to not work properly. e.g.,
image
image

I don't have a corporate proxy or anything.

@StefanScherer

This comment has been minimized.

Copy link

@StefanScherer StefanScherer commented Jun 16, 2019

Maybe the same as in microsoft/WSL#4133
Some tried --network host or reinstalled ubuntu.

@nicolasdelvat

This comment has been minimized.

Copy link
Author

@nicolasdelvat nicolasdelvat commented Jun 16, 2019

You're right, this is the same issue.
At first, I installed the docker.io package with apt and it looks like there is a difference in the settings.
With the script get.docker.com, it work like a charm now, thank you !

@benc-uk

This comment has been minimized.

Copy link

@benc-uk benc-uk commented Jun 16, 2019

Mine was working with bridge network, and suddenly it has stopped and now I have to use --network host

EDIT: Rebooted and it's working again. Seems kinda flaky

@StefanScherer

This comment has been minimized.

Copy link

@StefanScherer StefanScherer commented Jun 16, 2019

The IP address of the wsl2 VM seems very „random“ I haven‘t looked closer. But Docker uses a default container network 172.17.0.0/16 which may collide with the wsl2 IP address.

@benc-uk

This comment has been minimized.

Copy link

@benc-uk benc-uk commented Jun 16, 2019

Yes, my IP has been all sorts, across several ranges. It changes each boot too AFAIK.

Fingers crossed the localhost support isn't far off

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants
You can’t perform that action at this time.