Permalink
Browse files

Merge branch '3449_bump_glib_version'

  • Loading branch information...
zyv committed Oct 20, 2015
2 parents e0c16d7 + 16630ed commit 52fd328042a426e885da891c8ce8218cda3a1cf7
Showing with 9 additions and 15 deletions.
  1. +1 −1 doc/HACKING
  2. +3 −3 doc/INSTALL
  3. +1 −2 doc/INSTALL.FAST
  4. +0 −5 doc/README
  5. +4 −4 m4.include/ac-glib.m4
View
@@ -19,7 +19,7 @@ required:
Autoconf 2.52 and above (latest is recommended)
Automake 1.5 and above (latest is recommended)
Gettext 0.11.5 and above
Glib 2.14 and above
Glib 2.26 and above
Full list of requirements you can see at:
http://www.midnight-commander.org/wiki/doc/buildAndInstall/req
View
@@ -384,10 +384,10 @@ glib
The only "hard" dependency of GNU Midnight Commander is glib. You can
get glib from
ftp://ftp.gtk.org/pub/glib/
ftp://ftp.gnome.org/pub/gnome/sources/glib/
Minimal version of glib: 2.14.x
Recommended version: 2.14.x and higher.
Minimal version of glib: 2.26.x
Recommended version: 2.26.x and higher.
Newer versions may work, but haven't been tested.
View
@@ -1,7 +1,6 @@
Read the INSTALL file for the complete instructions.
GNU Midnight Commander requires glib2. You may already have glib
installed, but if you don't, take it from ftp://ftp.gtk.org/pub/gtk/
GNU Midnight Commander requires glib2.
GNU Midnight Commander uses the S-Lang screen library by default. It
tries the S-Lang library installed on the system. If it's not found,
View
@@ -28,11 +28,6 @@ included with this distribution package.
Dependencies
------------
To compile the GNU Midnight Commander, you need to have a copy of the
glib library version 2.14.x or newer, available at
ftp://ftp.gtk.org/pub/glib/
Please read the file INSTALL for installation instructions
and full list of dependencies.
View
@@ -8,12 +8,12 @@ AC_DEFUN([AC_G_MODULE_SUPPORTED], [
g_module_supported=""
found_gmodule=no
PKG_CHECK_MODULES(GMODULE, [gmodule-no-export-2.0 >= 2.14], [found_gmodule=yes], [:])
PKG_CHECK_MODULES(GMODULE, [gmodule-no-export-2.0 >= 2.26], [found_gmodule=yes], [:])
if test x"$found_gmodule" = xyes; then
g_module_supported="gmodule-no-export-2.0"
else
dnl try fallback to the generic gmodule
PKG_CHECK_MODULES(GMODULE, [gmodule-2.0 >= 2.14], [found_gmodule=yes], [:])
PKG_CHECK_MODULES(GMODULE, [gmodule-2.0 >= 2.26], [found_gmodule=yes], [:])
if test x"$found_gmodule" = xyes; then
g_module_supported="gmodule-2.0"
fi
@@ -78,9 +78,9 @@ AC_DEFUN([AC_CHECK_GLIB], [
AS_HELP_STRING([--with-glib-static], [Link glib statically @<:@no@:>@]))
glib_found=no
PKG_CHECK_MODULES(GLIB, [glib-2.0 >= 2.14], [glib_found=yes], [:])
PKG_CHECK_MODULES(GLIB, [glib-2.0 >= 2.26], [glib_found=yes], [:])
if test x"$glib_found" = xno; then
AC_MSG_ERROR([glib-2.0 not found or version too old (must be >= 2.14)])
AC_MSG_ERROR([glib-2.0 not found or version too old (must be >= 2.26)])
fi
])

0 comments on commit 52fd328

Please sign in to comment.