Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Incorrect empty string values in query results #3261

Closed
monetdb-team opened this issue Nov 30, 2020 · 0 comments
Closed

Incorrect empty string values in query results #3261

monetdb-team opened this issue Nov 30, 2020 · 0 comments

Comments

@monetdb-team
Copy link

@monetdb-team monetdb-team commented Nov 30, 2020

Date: 2013-03-22 18:46:48 +0100
From: Milena Ivanova <<M.Ivanova>>
To: SQL devs <>
Version: 11.15.7 (Feb2013-SP2)
CC: @drstmane, @skinkie

Last updated: 2013-05-06 16:10:40 +0200

Comment 18645

Date: 2013-03-22 18:46:48 +0100
From: Milena Ivanova <<M.Ivanova>>

Incorrect query results over a string column with no empty string values. Some queries show empty string as a result, others display correct values.

The problem is reproducible, it appears when the table has more than 5M rows, and the missing values are consistent (ranges rmm1-rmm10, 183-192, etc.)

table definition
create table rock_qtl3(
probename varchar(64),
markername varchar(64),
qtl real );

correct values
select * from rock_qtl3 where probename='AGIUSA1234' and markername like 'rmm_' limit 15;
+------------+------------+-----------------+
| probename | markername | qtl |
+============+============+=================+
| AGIUSA1234 | rmm1 | 0.107853971 |
| AGIUSA1234 | rmm2 | 0.107853971 |
| AGIUSA1234 | rmm3 | 0.107853971 |
| AGIUSA1234 | rmm4 | 0.158719465 |
| AGIUSA1234 | rmm5 | 0.107853971 |
| AGIUSA1234 | rmm6 | 0.107853971 |
| AGIUSA1234 | rmm7 | 0.107853971 |
| AGIUSA1234 | rmm8 | 0.130806118 |
| AGIUSA1234 | rmm9 | 0.0857530013 |
+------------+------------+-----------------+

incorrect values
select * from rock_qtl3 where probename='AGIUSA1234' limit 15;
+------------+------------+-----------------+
| probename | markername | qtl |
+============+============+=================+
| AGIUSA1234 | | 0.107853971 |
| AGIUSA1234 | | 0.107853971 |
| AGIUSA1234 | | 0.107853971 |
| AGIUSA1234 | | 0.158719465 |
| AGIUSA1234 | | 0.107853971 |
| AGIUSA1234 | | 0.107853971 |
| AGIUSA1234 | | 0.107853971 |
| AGIUSA1234 | | 0.130806118 |
| AGIUSA1234 | | 0.0857530013 |
| AGIUSA1234 | | 0.0850726515 |
| AGIUSA1234 | rmm11 | 0.178307399 |
| AGIUSA1234 | rmm12 | 0.275123864 |
| AGIUSA1234 | rmm13 | 0.145893753 |
| AGIUSA1234 | rmm14 | 0.145893753 |
| AGIUSA1234 | rmm15 | 0.0447690487 |
+------------+------------+-----------------+

Test data and scripts available in ~milena/monetdb_test

Comment 18673

Date: 2013-04-03 09:59:54 +0200
From: @drstmane

Bug #3268 appear to be related to this one.

I also vaguely recall having seen similar problems either in some other bug report or on a mailing list --- unfortunately, I don't recall the details ...

Comment 18674

Date: 2013-04-03 11:45:51 +0200
From: MonetDB Mercurial Repository <>

Changeset 745ff1012a26 made by Sjoerd Mullender sjoerd@acm.org in the MonetDB repo, refers to this bug.

For complete details, see http//devmonetdborg/hg/MonetDB?cmd=changeset;node=745ff1012a26

Changeset description:

Make sure the whole heap gets copied if that's what we want.
When going from malloced to mmapped heap memory, HEAPextend only
copies what it says in the free field.  When GDKupgradevarheap needs
to copy everything (copyall is set), we need to temporarily set free
to the size of the whole heap.
This fixes bug #3261, and presumably also bu 3268.

Comment 18678

Date: 2013-04-03 12:44:51 +0200
From: @sjoerdmullender

*** Bug #3268 has been marked as a duplicate of this bug. ***

Comment 18715

Date: 2013-05-06 16:09:32 +0200
From: MonetDB Mercurial Repository <>

Changeset bad6f014778c made by Sjoerd Mullender sjoerd@acm.org in the MonetDB repo, refers to this bug.

For complete details, see http//devmonetdborg/hg/MonetDB?cmd=changeset;node=bad6f014778c

Changeset description:

Added test for bug #3261.

Comment 18716

Date: 2013-05-06 16:10:40 +0200
From: @sjoerdmullender

Closing since the fix is already in the SP2 release and we now also have a test.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant