An Eve extension for MongoEngine ODM support
Python
Latest commit fe35500 Apr 29, 2015 @seglberg seglberg Merge pull request #18 from dexteradeus/feature/choices_fix
Allow choice fields with human readable key tuples

README.rst

Eve-MongoEngine

Info:Eve-MongoEngine provides MongoEngine integration with Eve.
Repository:https://github.com/hellerstanislav/eve-mongoengine
Author: Stanislav Heller (https://github.com/hellerstanislav)
Maintainer:Matthew Ellison (https://github.com/seglberg)

Production Development
travis-master travis-develop
Code Health Code Health

THE DEVELOP BRANCH CONTAINS POST-LEGACY WORK

See the legacy tag for the last legacy release (0.0.10).

Do not use develop in production code. Instead, the master branch always points to the latest production release, and should be used instead.

About

Eve-MongoEngine is an Eve extension, which enables MongoEngine ODM model to be used as an Eve / Cerberus schema. This eliminates the need to re-write API schemas in the Cerberus format by using MongoEngine models to automatically export a corresponding Cerberus schema.

Additional documentation and examples can be found on Read the Docs.

Installation

If you have pip installed you can use pip install eve-mongoengine. Otherwise, you can download the source from GitHub and run python setup.py install.

Dependencies

  • Python 2.7+ or Python 3.3+
  • eve>=0.5.3
  • mongoengine>=0.8.7,<=0.9
  • blinker

Optional Dependencies

  • None

Legacy Release

The legacy version of the extension can be found under the 'legacy' tag. The legacy version of the extension was released under the BSD-2 license and originally authored by Stanislav Heller. See AUTHORS for more information about the legacy authors and ownership.