Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

filter-select problems #161

Closed
1evan2 opened this Issue Oct 24, 2012 · 5 comments

Comments

Projects
None yet
2 participants

1evan2 commented Oct 24, 2012

Hi, I'm using the latest 2.4.5 version of tablesorter and the filter plugin and I am using class="filter-select" as indicated in the documentation.

However, even though the drop-down select appears, all of the content (no matter what is selected) disappears from the table. Select the default value of the drop down "Select your category" as part of data-placeholder always returns the entire table back to the page.

It would appear that the dropdown never finds the content. Is there a proper way to debug this?

Owner

Mottie commented Oct 24, 2012

Hi 1evan2!

Can you share some of the content within the table cells. I'm just guessing but maybe there are some special characters or HTML inside the table? If that is the case, you may need to use the filter_functions option

1evan2 commented Oct 24, 2012

I think you are right since I added a basic table to the same page and it correctly filters.

See example line below. I am filter-select ing on the column "Category".

<table border="1" id="specials" class="tablesorter">
            <thead>
            <tr>
            <th>&nbsp;</th>
            <th>Thumbnail</th>
            <th class="filter-select filter-match" data-placeholder="Select a Category">Category</th>
            <th>Air Date</th>
            <th>Title</th>
            <th>Post Date</th>
            <th>Enabled</th>
            <th>Featured</th>
            <th>Completed ?</th>
            </tr>
        </thead>
        <tbody>
        <tr><td><a href="https://admin.pegsystems.com/menu.php?func=specials&op=edit&id=1259">
            <img src="https://admin.pegsystems.com/images/edit.png" title="Edit this special"></a> | 
            <a href="https://admin.pegsystems.com/menu.php?func=specials&subop=delete&id=1259" onClick='return     confirm("Deleting a special will remove it permanently. Do you want to do this for: A'Mangiare's Grand Opening?");'>
        <img src="https://admin.pegsystems.com/images/delete.png" title="Delete this special"></a></td>
<td><img src="http://videos.pctv76.org/1259_small.jpg"></td><td>Pleasantville Public Access&nbsp;</td>
<td>2012-10-18&nbsp;</td>
<td>A'Mangiare's Grand Opening&nbsp;</td>
<td>2012-10-22&nbsp;</td>
<td><a href="https://admin.pegsystems.com/menu.php?func=specials&id=1259&enabled=false">disable</a>&nbsp;</td>  
<td><a href="https://admin.pegsystems.com/menu.php?func=specials&id=1259&featured=false">disable</a>&nbsp;</td>    
<td><img src="https://admin.pegsystems.com/images/checkon.png"></td></tr>'
Owner

Mottie commented Oct 24, 2012

Remove the &nbsp; from the end and it'll work... I'll have to trim out those spaces (which I thought I did) in the next update.

1evan2 commented Oct 24, 2012

Thanks! That worked perfectly!

@Mottie Mottie closed this in ce376f7 Oct 25, 2012

Owner

Mottie commented Oct 25, 2012

The filter widget will now automatically strip out extra spaces. :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment