New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Waterfox 56.0.2 new profile misbehaviour when choosing a profile that was created by Firefox 56.0.2 #371

Closed
grahamperrin opened this Issue Jan 11, 2018 · 2 comments

Comments

1 participant
@grahamperrin
Contributor

grahamperrin commented Jan 11, 2018

Steps

  1. with Firefox 56.0.2
  2. create a new profile
  3. use the profile
  4. add an extension
  5. about:profiles
  6. copy the path to the root directory
  7. quit Firefox
  8. with Waterfox 56.0.2
  9. about:profiles
  10. create a new profile
  11. click 'Next'
  12. click 'Choose folder…'
  13. choose the path that was copied at step (6) above
  14. click 'Finish'

Expected

  • either use of the chosen directory, and a usable extension
  • or successful import to a different directory, plus an on-screen notification about the difference (persisting until dismissed by the user)

Actual result

  • use of a different directory, no extension, and no notification about the difference.
@grahamperrin

This comment has been minimized.

Contributor

grahamperrin commented Jan 11, 2018

Workaround

If required:

  • quit Waterfox
  • manually edit the profiles.ini for Waterfox to truly use the Firefox-specific path that was preferred in step (13) above.

(I understand that Waterfox 56.0.2 reuse of a Firefox 56.0.2 profile directory might be unsupported, but for now (for 56.0.2) in some cases it's a very useful troubleshooting technique.)

@grahamperrin

This comment has been minimized.

Contributor

grahamperrin commented May 15, 2018

Things have improved considerably. Enough for me to close this issue without a detailed review.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment