Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

User Agent Override Requests #985

Open
MrAlex94 opened this issue May 22, 2019 · 38 comments

Comments

@MrAlex94
Copy link
Owner

commented May 22, 2019

If a website does not load properly because of a User Agent it does not recognise, please post it here, with a screenshot. The format of your post should be:

<URL here>
<Screenshot here>

⚠️ Please do not have discussions here. This is only for User Agent override requests for site that do not work.

Current (and requested) overrides:

  • addons.mozilla.org
  • netflix.com
  • chase.com
  • web.whatsapp.com
  • amazon.com
  • amazon.co.uk
  • amazon.de
  • amazon.co.jp
  • spotify.com
  • cosmicshambles.com
  • volunteerlogin.org
  • polar.com
  • eon.tv
  • slack.com
  • wire.com
  • trello.com
  • tresorit.com

@MrAlex94 MrAlex94 changed the title User Agent Override Request User Agent Override Requests May 22, 2019

@MrAlex94 MrAlex94 pinned this issue May 22, 2019

@grahamperrin

This comment was marked as resolved.

Copy link
Contributor

commented May 22, 2019

@OmaJantzen

This comment was marked as resolved.

@Nikolacc

This comment was marked as resolved.

Copy link

commented May 23, 2019

@EvilCronos

This comment has been minimized.

Copy link

commented May 24, 2019

YouTube new creator studio doesn't work and neither does Prime video, even after clearing my cache and restarting the browser. Using the latest update 56.2.10 64-bit on Windows 7 64-bit.

no youtube

prime

@ntrf

This comment was marked as resolved.

Copy link

commented May 24, 2019

URL: https://*.slack.com
Any Slack workspace. I can't share the exact workspace with you, 'cause it's private. It works fine if i set override as Mozilla/5.0 (Windows NT 10.0; Win64; rv:68.0) Gecko/20100101 Firefox/68.0
Screenshot

@DeepMac

This comment has been minimized.

Copy link

commented May 25, 2019

URL: https://rtpsecbeers.slack.com/messages

Confirmed this doesn't work in Slack spaces. See screenshot for this specific page
image

@georg-h

This comment has been minimized.

Copy link

commented May 26, 2019

@NekomanmaCc

This comment has been minimized.

Copy link

commented May 26, 2019

@HapaxOromenon

This comment has been minimized.

Copy link

commented May 27, 2019

@Geralt28

This comment was marked as off-topic.

Copy link

commented May 27, 2019

Can not put screenshots that is why i put link under:)

Whatsup web:
https://web.whatsapp.com/

https://screenshots.firefox.com/6osuD89sfgkTPJ8Y/web.whatsapp.com

Steam (not sure but dont work for me today and yesterday (this or white screen) - it works on chrome in the same time:
https://store.steampowered.com/

https://screenshots.firefox.com/7JcQAjSRqpvQ1SXC/store.steampowered.com

@Geralt28

This comment was marked as off-topic.

Copy link

commented May 27, 2019

Still dont see steam on the list. it is very important for me - does it dont work only for me?

@HapaxOromenon

This comment was marked as off-topic.

Copy link

commented May 27, 2019

Steam doesn't work for everyone, but MrAlex94 seems to be away, as he hasn't updated the list in 4 days. In the mean time, while we're waiting for him to fix it, you can use the extension User Agent Switcher (https://addons.mozilla.org/en-GB/firefox/addon/user-agent-switcher-revived/) to change the user agent string manually.

@Geralt28

This comment was marked as off-topic.

Copy link

commented May 27, 2019

Ok I understand. This is my last post here to not spam posts in this thread, but want to only say that this user agend add on does not work (it looks like it does not change anything - it still say i need firefox on whatsup and also can not use steam shop (maybe it is incompatible with current version).

@HapaxOromenon

This comment was marked as off-topic.

Copy link

commented May 27, 2019

Once you've installed the extension, you have to click the button which it placed in the top toolbar, then select a user agent of Firefox 56.

@Geralt28

This comment was marked as off-topic.

Copy link

commented May 27, 2019

of course i did it (also reloaded pages and start waterfox again):

NEXT edit:
It works and second time it does not. Guess that is why it did not worked 5 times and started to work. Some time i can enter page sometime not. For example when i enter web.whatsup it says i use bad browser but after i make ctr+shift+r it works. Steam usualy does not work, but somehow it worked at last once..

@HapaxOromenon

This comment was marked as off-topic.

Copy link

commented May 28, 2019

You could also try selecting Microsoft Edge as the user agent. That worked for me before when YouTube was broken.

@BillyTBum

This comment has been minimized.

Copy link

commented May 29, 2019

As of last night, Youtube appears to be broken with all current versions of Waterfox (tested 56.2.8 and 56.2.10). A rogue element loads and completely disaligns everything; a Reddit thread on the matter suggested I post screenshots here:

1559102706409
1559102950597

(Note: second screenshot is what it looks like when a video is loaded)

Results seem to vary according to the reddit thread, but this persisted for me even after adding a user agent override.

@LeeBinder

This comment has been minimized.

Copy link

commented May 29, 2019

Hello @MrAlex94 : hangouts.google.com needs a different one. No screenshot necessary - calls simply don't go through all the way until the phone rings, best tested by calling oneself ...

Details see my posting here

@grahamperrin

This comment has been minimized.

Copy link
Contributor

commented May 30, 2019

YouTube new creator studio

https://studio.youtube.com/

Discussion: https://redd.it/buqvm2

@LeeBinder

This comment has been minimized.

Copy link

commented May 30, 2019

The thread over at hangouts.google.com needs some more contributors, esp. (but not limited to) Linux / FreeBSD users. So head on over and share your findings over there, please.

@zenerbufen

This comment was marked as off-topic.

Copy link

commented Jun 3, 2019

spotify web player broken with new user agent, wants me to 'upgrade' to firefox to jam out to tunes

@MrAlex94

This comment has been minimized.

Copy link
Owner Author

commented Jun 6, 2019

Added requests 3d73512

@c33s

This comment has been minimized.

Copy link

commented Jun 8, 2019

not sure if its an user agent or the sites owners issue. https://dev.to is broken on waterfox (worked before. don't know the date when it started to be broken).

see thepracticaldev/dev.to#3081

@mindwarp42

This comment was marked as resolved.

Copy link

commented Jun 10, 2019

Site: https://www.hoopladigital.com
Screenshot:
Hoopla in Waterfox 56 2 10

I use portable Waterfox at library I work at - this is one of the downloadable media options we offer, and the only one that isn't working with Waterfox unless I spoof the user agent currently.

@grahamperrin

This comment was marked as resolved.

Copy link
Contributor

commented Jun 11, 2019

@grahamperrin

This comment was marked as resolved.

Copy link
Contributor

commented Jun 15, 2019

@xbipin

This comment was marked as resolved.

Copy link

commented Jun 17, 2019

@grahamperrin

This comment was marked as resolved.

Copy link
Contributor

commented Jun 17, 2019

image

@MrAlex94

This comment has been minimized.

Copy link
Owner Author

commented Jun 19, 2019

@grahamperrin

This comment has been minimized.

Copy link
Contributor

commented Jun 21, 2019

https://internet.xfinity.com/

image

@grahamperrin

This comment has been minimized.

Copy link
Contributor

commented Jun 21, 2019

https://www.reddit.com/comments/c34fej/-/etmpi8g/?context=1 tl;dr I no longer suspect a UA issue with Lifehacker.

@grahamperrin

This comment has been minimized.

Copy link
Contributor

commented Jun 21, 2019

https://www.reddit.com/comments/c34fej/-/etmpi8g/?context=1 tl;dr I no longer suspect a UA issue with The Onion.

@fontmaniac

This comment has been minimized.

Copy link

commented Jun 23, 2019

https://banking.westpac.com.au

Basically, Westpac online banking refuses to login with non-standard useragent. It doesn't show any specific message, just repeatedly shows login screen. Setting general.useragent.override to something standard fixes it.

@reluctantuser

This comment has been minimized.

Copy link

commented Jun 26, 2019

Waterfox 56.2.11, Windows 7 fully patched, 64-bit

Google Apps spreadsheets go into continuous reload cycle. Spreadsheet never stabilizes so that any aspect of the spresheet can be clicked. Spreadsheet buttons/features never become useable.

Issue began within the past 24 hours. Error reports to Google go unanswered.

https://docs.google.com/spreadsheets/[link to actual spreadsheet]

Actual spreadsheet cannot be provided because it is a private, "secure" property that I do not control. Access to the spreadsheet is controlled by Google login credentials.

Error message in box:
Unable to load file
Try to load it again or send an error report.
[Reload button]

When the reload button is pressed, the spreadsheet starts to reload but tosses the same error. You can click reload for 5 minutes or more and it does not help at all.

Exact same links (we have multiple spreadsheets) have been tested and they work 100% correct in "Portable Opera" from PortableApps, Version 60.0.3255.165

Perhaps Google or at least Google Apps needs to be added to the UA Override Request list

@grahamperrin

This comment has been minimized.

@grahamperrin

This comment has been minimized.

@grahamperrin

This comment has been minimized.

Copy link
Contributor

commented Aug 8, 2019

@fontmaniac please join the discussion at https://www.reddit.com/comments/ccduyc/-/evv121q/ – include a note of the user agent that works for you. Thanks

@hawkeye116477

This comment has been minimized.

Copy link
Contributor

commented Aug 22, 2019

Is override ua possible for uBlock Origin? It seems that html filtering works now, but if someone add that filter in condition !#if cap_html_filtering, then it's not applied and I see that's because of following line on uBO => https://github.com/gorhill/uBlock/blob/c34326cf4e191c2ee2723523d0a57fa4d9f425bd/platform/chromium/vapi-common.js#L68, so it checks if it's Firefox 57.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
You can’t perform that action at this time.