Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

MudTable MultiSelection check-all bug #1469

Closed
lskyum opened this issue Apr 29, 2021 · 4 comments
Closed

MudTable MultiSelection check-all bug #1469

lskyum opened this issue Apr 29, 2021 · 4 comments
Labels
bug Something does not work as intended/expected fixed Fix has been merged
Milestone

Comments

@lskyum
Copy link

lskyum commented Apr 29, 2021

Describe the bug
Using a MudTable with FixedHeader=true, MultiSelection=true. When scrolled a bit down, the checkbox below the header will catch mouse input instead of the "select all" checkbox. (MudBlazor version 5.0.8)

Expected behavior
When clicking the "select all" checkbox in the header, the checkbox scrolled under it, should not be affected.

TryMudBlazor
https://try.mudblazor.com/snippet/mYmPaeGDhGTnfCrS

Screenshots
MudTable  issue

@lskyum lskyum added the bug Something does not work as intended/expected label Apr 29, 2021
@porkopek
Copy link
Contributor

The problem is in this code

.mud-table-sticky-header * .mud-table-root .mud-table-head * .mud-table-cell {
    background-color: var(--mud-palette-surface);
    position: sticky;
    z-index: 1;   <== HERE 
    top: 0;
}

Incrementing the z-index to 2 seems enough to solve this.

Do you want to make a PR?

@porkopek
Copy link
Contributor

porkopek commented Apr 30, 2021

As a work around, you can solve your issue in your code adding this

.mud-table-sticky-header * .mud-table-root .mud-table-head * .mud-table-cell {
    z-index: 2; 
}

to your CSS sheet

@lskyum
Copy link
Author

lskyum commented May 1, 2021

Thank you for the workaround, it works just fine now.

@lskyum
Copy link
Author

lskyum commented May 1, 2021

Attempted to make a PR (https://github.com/Garderoben/MudBlazor/pull/1477) hope I did it right, because it's my first PR ever :-)

@mikes-gh mikes-gh added the fixed Fix has been merged label May 2, 2021
@mikes-gh mikes-gh added this to the 5.0.9 milestone May 2, 2021
@mikes-gh mikes-gh closed this as completed May 6, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
bug Something does not work as intended/expected fixed Fix has been merged
Projects
None yet
Development

No branches or pull requests

3 participants