Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Render delay when using TreeView on-demand load #1585

Closed
nguyenhthai opened this issue May 17, 2021 · 1 comment · Fixed by #1592
Closed

Render delay when using TreeView on-demand load #1585

nguyenhthai opened this issue May 17, 2021 · 1 comment · Fixed by #1592
Labels
bug Something does not work as intended/expected
Milestone

Comments

@nguyenhthai
Copy link

Describe the bug
Before #1406 had been implemented, I created a custom solution to handle on demand load when expanding the tree node. It worked very well for me and now with the release of 5.0.9 that has the support for it built-in, I thought I would try to switch out for that. However, upon trying the new behavior, I cannot understand why there is a delay for rendering the on-demand load data. Based on the documentation, there is a Task.Delay for 500ms but if you take that one out, it still takes time to render the children tree. I attached a snippet from TryMudBlazor to demonstrate the issue and the comparison with my custom solution as well. If you look at it, my solution renders much faster than the new on-demand load. Even if I try adding a delay to show the loading button animation, my solution would be still faster.

Expected behavior
Tree item children nodes should be rendered without substantial delay.

TryMudBlazor
https://try.mudblazor.com/snippet/caclufvLrtIdbyjg. Expand the node "Categories".

@nguyenhthai nguyenhthai added the bug Something does not work as intended/expected label May 17, 2021
@tungi52
Copy link
Contributor

tungi52 commented May 18, 2021

Interesting. There is no built-in delay, the documentation has it only to demonstrate the loading state. I think the problem will be the expand-collapse animation.

henon pushed a commit that referenced this issue May 23, 2021
Co-authored-by: Tangl András <tangladr@schaeffler.com>
@henon henon added this to the 5.0.10 milestone May 23, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
bug Something does not work as intended/expected
Projects
None yet
Development

Successfully merging a pull request may close this issue.

3 participants