Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

MudSelect + SelectAll="true" + empty list affects checkbox #2651

Closed
Yomodo opened this issue Sep 6, 2021 · 6 comments · Fixed by #2653
Closed

MudSelect + SelectAll="true" + empty list affects checkbox #2651

Yomodo opened this issue Sep 6, 2021 · 6 comments · Fixed by #2653
Labels
bug Something does not work as intended/expected fixed Fix has been merged

Comments

@Yomodo
Copy link
Contributor

Yomodo commented Sep 6, 2021

Describe the bug
Using MudSelect with SelectAll="true" and no default items (empty list),
still affects the tri-state checkbox.

Expected behavior
When using an empty list/there's no selection, the checkbox should also be "empty".

TryMudBlazor
https://try.mudblazor.com/snippet/QEGPEDEAUPCPblJH

Screenshots
image

@Yomodo Yomodo added the triage label Sep 6, 2021
@boukenka
Copy link
Contributor

boukenka commented Sep 6, 2021

@Yomodo Thanks to report it. I will have a look.

@Santhosh-Krishnamoorthy
Copy link

Also, on load, if you bind the selected values to all the available values, even then the select all checkbox loads in tristate.
image

@boukenka
Copy link
Contributor

boukenka commented Sep 6, 2021

@Santhosh-Krishnamoorthy Could you provide a Try.MudBlazor please.

@Santhosh-Krishnamoorthy
Copy link

Apologies, forgot to add the link.
Could you please try this link?
https://try.mudblazor.com/snippet/wamPuDYAAVLNlhFK

@boukenka
Copy link
Contributor

boukenka commented Sep 6, 2021

@Santhosh-Krishnamoorthy @Yomodo Thank you both. A PR has provided for this problem. Sorry for the inconvenience.

@Yomodo
Copy link
Contributor Author

Yomodo commented Sep 6, 2021

@boukenka Thank you for the quick fix!

henon pushed a commit that referenced this issue Sep 10, 2021
* SelectAll fix

* Method has been renamed after review
@JonBunator JonBunator added bug Something does not work as intended/expected fixed Fix has been merged and removed triage labels Sep 10, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
bug Something does not work as intended/expected fixed Fix has been merged
Projects
None yet
Development

Successfully merging a pull request may close this issue.

4 participants