Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Multiple use of "group" in list command broken #408

Open
djselbeck opened this Issue Nov 5, 2018 · 2 comments

Comments

Projects
None yet
3 participants
@djselbeck
Copy link

djselbeck commented Nov 5, 2018

Since MPD 0.20.22 the repeatedly use of "group" within the list command is broken.

The command

list album group musicbrainz_albumid works as expected whereas

list album group musicbrainz_albumid group albumartist results in

ACK [2@0] {list} not able to parse args

The protocol documentation states:

Additional arguments may specify a filter. The group keyword may be used (repeatedly) to group the results by one or more tags.

So I think it is a valid use of the group feature

@MaxKellermann MaxKellermann added the bug label Nov 12, 2018

@fuchsmich

This comment has been minimized.

Copy link

fuchsmich commented Feb 15, 2019

Are you sure this bug didn't exist in version prior to 0.20.22?

@djselbeck

This comment has been minimized.

Copy link
Author

djselbeck commented Mar 9, 2019

Yes, 0.20.21 works correctly.

Are there any news on this issue?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.