Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

freeze on one track #642

Open
installgentoo opened this issue Sep 11, 2019 · 3 comments

Comments

@installgentoo
Copy link

commented Sep 11, 2019

Bug report

Describe the bug

When you have a single song on a looped playlist mpd will sometimes freeze when it finishes. Seems to be happening for a while now, my options are [zxc], nothing's in logs- mpd just locks up with 0 cpu usage and can only be killed with -9, so it's a deadlock i presume. I couldn't catch this on debug build. Switching to next song manually while having one song does not cause the bug.

Expected Behavior

Actual Behavior

Version

Music Player Daemon 0.21.14 (0.21.14)
Copyright 2003-2007 Warren Dukes warren.dukes@gmail.com
Copyright 2008-2018 Max Kellermann max.kellermann@gmail.com
This is free software; see the source for copying conditions. There is NO
warranty; not even MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Database plugins:
simple

Storage plugins:
local

Decoders plugins:
[dsdiff] dff
[dsf] dsf
[hybrid_dsd] m4a
[ffmpeg] 16sv 3g2 3gp 4xm 8svx aa3 aac ac3 adx afc aif aifc aiff al alaw amr anim apc ape asf atrac au aud avi avm2 avs bap bfi c93 cak cin cmv cpk daud dct divx dts dv dvd dxa eac3 film flac flc fli fll flx flv g726 gsm gxf iss m1v m2v m2t m2ts m4a m4b m4v mad mj2 mjpeg mjpg mka mkv mlp mm mmf mov mp+ mp1 mp2 mp3 mp4 mpc mpeg mpg mpga mpp mpu mve mvi mxf nc nsv nut nuv oga ogm ogv ogx oma ogg omg opus psp pva qcp qt r3d ra ram rl2 rm rmvb roq rpl rvc shn smk snd sol son spx str swf tak tgi tgq tgv thp ts tsp tta xa xvid uv uv2 vb vid vob voc vp6 vmd wav webm wma wmv wsaud wsvga wv wve
[pcm]

Filters:
soxr

Tag plugins:

Output plugins:
null alsa httpd

Encoder plugins:
null lame wave

Input plugins:
file alsa ffmpeg

Playlist plugins:
extm3u m3u pls

Protocols:
file:// alsa:// gopher:// rtp:// rtsp:// rtmp:// rtmpt:// rtmps://

Other features:
epoll icu inotify tcp un

Log

@MaxKellermann

This comment has been minimized.

Copy link
Member

commented Sep 13, 2019

Need verbose log and backtrace.

@installgentoo

This comment has been minimized.

Copy link
Author

commented Sep 14, 2019

i've just caught this with logs on verbose.

there's nothing in log. mpd just freezes.

@MaxKellermann

This comment has been minimized.

Copy link
Member

commented Sep 14, 2019

If there's nothing in the log file, then either you're looking at the wrong file or MPD isn't playing anything. MPD logs at start and end of playback.
And don't forget the backtrace. I'm unable to analyze your problem without full information.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.