Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We鈥檒l occasionally send you account related emails.

Already on GitHub? Sign in to your account

Could not install package 'MvvmCross.Plugin.PictureChooser 5.4.2' into a "Profile78" project #2369

Closed
neminush opened this issue Nov 8, 2017 · 5 comments

Comments

Projects
None yet
2 participants
@neminush
Copy link

commented Nov 8, 2017

Expected behavior 馃

I would like to install a part of the plugin into portable library

Actual behavior 馃悰

Could not install package 'MvvmCross.Plugin.PictureChooser 5.4.2'. You are trying to install this package into a project that targets '.NETPortable,Version=v4.5,Profile=Profile78', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author.

Configuration 馃敡

Version: 5.4.2

Platform:

  • :portable library: .net v4.5, Profile78
@Cheesebaron

This comment has been minimized.

Copy link
Member

commented Nov 8, 2017

PictureChooser is a Profile259 PCL. So it can't be consumed in Profile78 since 78 contains WP8.

Do you need to support WP8?

@neminush

This comment has been minimized.

Copy link
Author

commented Nov 9, 2017

Thanks for the reply.
I don't know yet whether I will need support WP8.

@neminush

This comment has been minimized.

Copy link
Author

commented Nov 9, 2017

I have changed profile for the PCL project from Profile78 to Profile259. Then I have tried to install the 'MvvmCross.Plugin.PictureChooser 5.4.2' and got the following message:

"Could not install package 'MvvmCross.Plugin.PictureChooser 5.4.2'. You are trying to install this package into a project that targets '.NETPortable,Version=v4.5,Profile=Profile259', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author."

@neminush

This comment has been minimized.

Copy link
Author

commented Nov 9, 2017

Profile111 fits for the plugin.

@Cheesebaron

This comment has been minimized.

Copy link
Member

commented Nov 9, 2017

You are better off creating a NET Standard class library instead and use that. Then you don't need to fiddle around with different PCL profiles.

@Cheesebaron Cheesebaron closed this Nov 9, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can鈥檛 perform that action at this time.