Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

In mythplugins update configure check to QT 4.8 minimum

  • Loading branch information...
commit 4c8e5e3a091341c4f3bfca124890e08eacca4313 1 parent 9d670e8
@stuartm stuartm authored
Showing with 4 additions and 4 deletions.
  1. +4 −4 mythplugins/configure
View
8 mythplugins/configure
@@ -521,7 +521,7 @@ EOF
fi
is_qmake4(){
- $1 --version 2>&1 | egrep -q -e "Qt version 4\.[5-9]\.[0-9]"
+ $1 --version 2>&1 | egrep -q -e "Qt version 4\.[8-9]\.[0-9]"
}
# bring in mythtv config
@@ -559,11 +559,11 @@ EXTRALIBS=$(cat mythconfig.mak | grep -e "^EXTRALIBS=")
EXTRALIBS=${EXTRALIBS#EXTRALIBS=}
if ! is_qmake4 $qmake; then
- is_qmake4 qmake-qt4 && qmake=qmake-qt4 || die "qmake for Qt4.6 or newer not found.\nPlease specify the correct qmake with --qmake="
+ is_qmake4 qmake-qt4 && qmake=qmake-qt4 || die "qmake for Qt4.8 or newer not found.\nPlease specify the correct qmake with --qmake="
fi
-if ! expr $($qmake -query QT_VERSION) : "4\.[6-9]\.[0-9]" >/dev/null; then
- die "Qt4.6 or newer is required to build MythTV."
+if ! expr $($qmake -query QT_VERSION) : "4\.[8-9]\.[0-9]" >/dev/null; then
+ die "Qt4.8 or newer is required to build MythTV."
fi
# rely on what was discover during MythTV configure
Please sign in to comment.
Something went wrong with that request. Please try again.