Permalink
Browse files

OpenGL: Drop the GLSL version to 1.0

This is the version that aligns with OpenGL 2.0/ES
  • Loading branch information...
Mark Kendall
Mark Kendall committed Feb 9, 2011
1 parent e4546b6 commit f18c31fc9ef2d7f215b4ae4bd093dd71cbec246f
Showing with 2 additions and 1 deletion.
  1. +2 −1 mythtv/libs/libmythui/mythrender_opengl2.cpp
@@ -160,6 +160,7 @@ bool MythRenderOpenGL2::InitFeatures(void)
m_glBindAttribLocation &&
m_glVertexAttrib4f && glslshaders)
{
+ VERBOSE(VB_GENERAL, LOC + QString("GLSL supported"));
m_exts_supported += kGLSL;
}
@@ -549,7 +550,7 @@ bool MythRenderOpenGL2::CheckObjectStatus(uint obj)
void MythRenderOpenGL2::OptimiseShaderSource(QString &source)
{
- QString version = "#version 120\n";
+ QString version = "#version 100\n";
QString extensions = "";
QString sampler = "sampler2D";
QString texture = "texture2D";

0 comments on commit f18c31f

Please sign in to comment.