Adds IDE-like features for NSIS development in Sublime Text
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
Commands
Preferences
Snippets
Support
Syntaxes
.gitignore
.no-sublime-package
.travis.yml
NSIS.sublime-settings
README.md
gulpfile.js
linter.py
package.json
repository.json
screenshot.png
yarn.lock

README.md

NSIS IDE for Sublime Text 3

The MIT License Apache License GitHub David Travis Gitter

A collection of useful NSIS packages for Sublime Text 3 (Build 3084 or higher).

Screenshot

Includes

Installation

Package Control

The easiest way to install is via Package Control.

  1. Add our repository https://nsis-dev.github.io/sublime-nsis-ide/repository.json
  2. Choose “Install package” from the Command Palette (Super+Shift+p)
  3. Select “NSIS IDE” and press Enter

With auto_upgrade enabled, Package Control will keep all installed packages up-to-date!

GitHub

Change to your Sublime Text Packages directory, then clone this repository as “NSIS IDE”:

$ git clone https://github.com/NSIS-Dev/sublime-nsis-ide.git 'NSIS IDE'

Building

Before using this plugin, you must ensure that makensis (NSIS v3.0 or higher) is installed on your system. To install makensis, do the following:

Windows

With NSIS installed, make sure makensis is in your PATH environmental variable.

Linux

Install makensis from your distribution's default package manager, for example:

# Debian
$ sudo apt-get install nsis

# Red Hat
$ sudo dnf install nsis

macOS

Install makensis through Homebrew:

# Homebrew (recommended)
$ brew install nsis

# MacPorts
$ ports install nsis

Linting

SublimeLinter 3 must be installed in order to use the linter.

In order for makensis to be executed by SublimeLinter, you must [ensure that its path is available][path] to SublimeLinter. Before going any further, please read and follow the steps in “Finding a linter executable” through “Validating your PATH” in the documentation.

Use the Command Palette to set up your linting preferences, or to run the linter.

Nightly Versions

With Node installed, you can keep the package at bleeding edge. Simply run yarn upgrade || npm update in the folder of this package.

License

This package is largely released under The MIT License, except NSIS language definitions and Windows build system, both released under the Apache License.