Skip to content

NSchrading/intro-spacy-nlp

master
Switch branches/tags
Code

Latest commit

 

Git stats

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
 
 
 
 

Introduction to spaCy for NLP and Machine Learning

Dependencies

spaCy

Scikit-learn

NLTK

To get the above requirements (except spaCy) download and install anaconda: https://store.continuum.io/cshop/anaconda/

To install spaCy:

pip install spacy
python -m spacy.en.download all

Make sure to run the above python command, this downloads the models that spaCy needs. Python 3 is recommended, although Python 2 should work as long as you convert the strings to unicode objects.

Running the files

  1. From the command line (cmd) or terminal navigate to where this readme and .ipynb file is.
  2. execute "ipython notebook Intro_spaCy_NLP"

About

An introduction to using spaCy for NLP and machine learning

Resources

License

Stars

Watchers

Forks

Releases

No releases published

Packages

No packages published