Permalink
Browse files

Regenerate models for corrected FK. #1973.

This model had an incorrect FK mapping in ncs_mdes 0.6.0. The mapping is fixed
in ncs_mdes 0.6.1.
  • Loading branch information...
1 parent 12e922f commit 7103fb39ea931e5369e653ad6a0575a700d2ca15 @rsutphin rsutphin committed Jun 11, 2012
@@ -17,7 +17,7 @@ class PregVisit1Heat2_2
NcsNavigator::Warehouse::DataMapper::NcsString,
{ :key => true, :required => true, :length => 1..36 }
belongs_to :pv1,
- 'NcsNavigator::Warehouse::Models::TwoPointOne::PregVisit_2',
+ 'NcsNavigator::Warehouse::Models::TwoPointOne::PregVisit_1_2',
:child_key => [ :pv1_id ], :required => true
property :heat2,
NcsNavigator::Warehouse::DataMapper::NcsString,
@@ -17,7 +17,7 @@ class PregVisit1Heat2_2
NcsNavigator::Warehouse::DataMapper::NcsString,
{ :key => true, :required => true, :length => 1..36 }
belongs_to :pv1,
- 'NcsNavigator::Warehouse::Models::TwoPointTwo::PregVisit_2',
+ 'NcsNavigator::Warehouse::Models::TwoPointTwo::PregVisit_1_2',
:child_key => [ :pv1_id ], :required => true
property :heat2,
NcsNavigator::Warehouse::DataMapper::NcsString,
@@ -15,7 +15,7 @@ Gem::Specification.new do |s|
s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
s.require_paths = ["lib", "generated_models"]
- s.add_dependency 'ncs_mdes', '~> 0.6'
+ s.add_dependency 'ncs_mdes', '~> 0.6', '>= 0.6.1'
s.add_dependency 'ncs_navigator_configuration', '~> 0.2'
s.add_dependency 'activesupport', '~> 3.0'

0 comments on commit 7103fb3

Please sign in to comment.