Join GitHub today
GitHub is home to over 28 million developers working together to host and review code, manage projects, and build software together.Sign up
Compatibility issues with jQuery 1.3.2 - is there a minimum version requirement #6
Hey there -
I'm noticing some issues when using ICE with TinyMCE under jQuery 1.3.2. Most obvious issue is what appears to be with Rangy, in that the selecting text and typing to replace doesn't work as intended. The text to be overwritten remains as normal text (doesn't contain the .del class) and the new typed text appears as new text highlighted with the .ins class.
Using jQuery versions 1.4 and above resolves the issue, but this causes other breakage in our CMS (Drupal). Is there a minimum requirement for jQuery version for ICE?
I was also wondering if it would be possible to set up ICE to run in its own jQuery namespace so that if there is a minimum version requirement it could be run in jQuery's noConflict mode and we could include the newer jQuery library specifically for ICE, but still use jQuery 1.3.2 for our CMS.
A somewhat related question, is there a minimum version of TinyMCE that is required?
referenced this issue
Feb 10, 2012
Sorry for the late reply on this one. I didn't have time to get a good answer on this. I haven't been able to test against old versions of jQuery, but it sounds like 1.4+ is the best version for ice. I will update the docs with this information. Tinymce seems to change a lot from release to release and I think we have been using ice with 3.4.x+ and 3.5.x+.