Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Removed upper bound node.js version restriction

  • Loading branch information...
commit 49fa32f40382e253533d0d6d607ad2694f7c87c6 1 parent 913f2ce
Mike Smathers msmathers authored
Showing with 15 additions and 10 deletions.
  1. +5 −0 History.md
  2. +5 −5 README.md
  3. +5 −5 package.json
5 History.md
View
@@ -1,3 +1,8 @@
+# 0.2.7 / 2012-06-18
+
+- Updated install.sh to use useradd instead of adduser for better linux support
+- Eased version restrictions on dependencies, removed upper bound of node.js version
+
# 0.2.6 / 2012-03-02
- Updated connect.js dependency to <=1.8.4
10 README.md
View
@@ -11,13 +11,13 @@ Users create *stream* and *history* screens to view and search log messages.
## Requirements
-[node.js](http://nodejs.org) (>=0.4.9 <=0.6.11)
+[node.js](http://nodejs.org) (>=0.4.9)
-[socket.io](http://socket.io) (0.9.0)
+[socket.io](http://socket.io) (>=0.9.0)
-[socket.io-client](https://github.com/LearnBoost/socket.io-client) (0.9.0)
+[socket.io-client](https://github.com/LearnBoost/socket.io-client) (>=0.9.0)
-[forever](https://github.com/indexzero/forever) (0.8.2)
+[forever](https://github.com/indexzero/forever) (>=0.8.2)
[connect](http://senchalabs.github.com/connect/) (<=1.8.4)
@@ -25,7 +25,7 @@ Users create *stream* and *history* screens to view and search log messages.
## Compatibility
-Harvesters & server have been tested on *Ubuntu 11.10*
+Harvesters & server have been tested on *Ubuntu 12.04*
Web clients have been tested on *Chrome*, *Safari*, and *Firefox*.
10 package.json
View
@@ -1,6 +1,6 @@
{
"name": "log.io",
- "version": "0.2.6",
+ "version": "0.2.7",
"description": "Real-time log monitoring in your browser",
"homepage": "http://logio.org",
"keywords": ["logs", "monitoring", "realtime", "socket.io", "node.js", "ajax"],
@@ -13,9 +13,9 @@
"url": "https://github.com/NarrativeScience/Log.io"
},
"dependencies": {
- "forever": "0.8.2",
- "socket.io": "0.9.0",
- "socket.io-client": "0.9.0",
+ "forever": ">=0.8.2",
+ "socket.io": ">=0.9.0",
+ "socket.io-client": ">=0.9.0",
"connect": "<=1.8.4",
"underscore": ">=1.1.7"
},
@@ -24,5 +24,5 @@
"postupdate": "bin/install.sh"
},
"main": "index",
- "engines": { "node": ">=0.4.9 <=0.6.11" }
+ "engines": { "node": ">=0.4.9" }
}
Please sign in to comment.
Something went wrong with that request. Please try again.