Skip to content
Trevor Seward edited this page Jan 17, 2020 · 2 revisions

SharePoint Patch Script PowerShell Module

This module consists of a suite of cmdlets to assist in retrieving information about a patch or installing a patch to your SharePoint server.

The module can be placed in the user’s Modules folder to enable auto-loading of the module under %USERPROFILE%\Documents\WindowsPowerShell\SharePointPatchScript\SharePointPatchScript.psm1 or to make the module available system-wide, under %ProgramFiles\WindowsPowerShell\Modules\SharePointPatchScript\SharePointPatchScript.psm1.

Note that this requires PowerShell version 3.0 and thus is not compatible with SharePoint 2010 farms as this module uses SharePoint cmdlets which on SharePoint 2010 require PowerShell 2.0. On SharePoint 2010 farms, you may import the module using:

Import-Module SharePointPatchScript.psm1

See the sidebar for specific cmdlet usage.

You can’t perform that action at this time.